POJ 1984 Navigation Nightmare

Navigation Nightmare
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 4590 Accepted: 1731
Case Time Limit: 1000MS

Description

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n): 
           F1 --- (13) ---- F6 --- (9) ----- F3

            |                                 |

           (3)                                |

            |                                (7)

           F4 --- (20) -------- F2            |

            |                                 |

           (2)                               F5

            | 

           F7 

Being an ASCII diagram, it is not precisely to scale, of course. 

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path 
(sequence of roads) links every pair of farms. 

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road: 

There is a road of length 10 running north from Farm #23 to Farm #17 
There is a road of length 7 running east from Farm #1 to Farm #17 
... 

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob: 

What is the Manhattan distance between farms #1 and #23? 

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms. 
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points). 

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1". 

Input

* Line 1: Two space-separated integers: N and M



* Lines 2..M+1: Each line contains four space-separated entities, F1,

        F2, L, and D that describe a road. F1 and F2 are numbers of

        two farms connected by a road, L is its length, and D is a

        character that is either 'N', 'E', 'S', or 'W' giving the

        direction of the road from F1 to F2.



* Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's

        queries



* Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob

        and contains three space-separated integers: F1, F2, and I. F1

        and F2 are numbers of the two farms in the query and I is the

        index (1 <= I <= M) in the data after which Bob asks the

        query. Data index 1 is on line 2 of the input data, and so on.

Output

* Lines 1..K: One integer per line, the response to each of Bob's

        queries.  Each line should contain either a distance

        measurement or -1, if it is impossible to determine the

        appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13. 
At time 3, the distance between 1 and 4 is still unknown. 
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10. 

Source



并查集的灵活运用。因为这道题的距离很特殊,是建立在二维坐标系中的距离|xi-xj|+|yi-yj|,所以两点之间的距离可以通过对于他们到同一祖先的距离相减而得,若两点非同一祖先,那就表示它们的距离目前无法确定。这道题细节要处理不少,适合长时间没做题目的人热热手。.


代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<ctime>
#include<string>
#include<cstring>
#include<algorithm>
#include<fstream>
#include<queue>
#include<stack> 
#include<vector>
#include<cmath>
#include<iomanip>
#define rep(i,n) for(i=1;i<=n;i++)
#define MM(a,t) memset(a,t,sizeof(a))
#define INF 1e9
typedef long long ll;
#define mod 1000000007
using namespace std;
class node{
  public:
	int fa,hen,shu;
	node(){}
	node(int f,int h1,int s1){
	  fa=f; hen=h1; shu=s1;	
	}
	void set(int f,int h1,int s1){
	  fa=f; hen=h1; shu=s1;
	}
}a[40020];
class route{
  public:
    int s,e,d;
	char ccc;	
	route(){}
	route(int s1,int e1,int d1,char c1){
	  s=s1; e=e1; d=d1; ccc=c1;	
	}
	void set(int s1,int e1,int d1,char c1){
	  s=s1; e=e1; d=d1; ccc=c1;	
	}
}r[40020];
class query{
  public:
    int s,e,time,index;
    query(){}
    query(int s1,int e1,int t1,int i1){
      s=s1; e=e1; time=t1; index=i1;	
    }
    void set(int s1,int e1,int t1,int i1){
      s=s1; e=e1; time=t1; index=i1;	
    }
}q[10020];
int getfa(int ii){
	int fa=a[ii].fa,hen=a[ii].hen,shu=a[ii].shu;
    if(fa!=a[fa].fa){	
  	    getfa(fa);
        hen+=a[fa].hen;
        shu+=a[fa].shu;
		fa=a[fa].fa;
    }
	a[ii].set(fa,hen,shu);	
    return fa;
}
bool cmp(query a,query b){
	return a.time<b.time;
}
char chf(char x){
  switch(x){
    case 'W':return 'E';	
    case 'E':return 'W';
    case 'N':return 'S';	
    case 'S':return 'N';
  }	
}
int n,m,k,ans[10020];
int main()
{
	int i,j,tt;
	
	scanf("%d%d",&n,&m);
		rep(i,n){
			a[i].fa=i;
			a[i].hen=0;
			a[i].shu=0;
		}
		rep(i,m){
		  int s,e,d;
		  char ccc;
		  scanf("%d%d%d %c",&s,&e,&d,&ccc);
          r[i].set(s,e,d,ccc);
		}
		scanf("%d",&k);
		rep(i,k){
		  int s,e,time;
		  scanf("%d%d%d",&s,&e,&time);
		  q[i].set(s,e,time,i);	
		}
		sort(q+1,q+k+1,cmp);
		tt=0;
		rep(i,k){
		  if(q[i].time>tt){
  		    for(j=tt+1;j<=q[i].time;j++){
   			  int s=r[j].s,e=r[j].e,d=r[j].d,hen,shu;
		      char ccc=r[j].ccc;
		      int f1=getfa(s),f2=getfa(e);
		      hen=-a[s].hen+a[e].hen; shu=-a[s].shu+a[e].shu;
		      if(f1<f2){
      		    swap(f1,f2);
				ccc=chf(ccc);
				hen=-hen;
				shu=-shu;	
      		  }
      		  if(f1==f2) continue;
      		  a[f1].fa=f2;
              switch(ccc){
                case 'W':a[f1].hen=hen-d; a[f1].shu=shu; break;
                case 'S':a[f1].hen=hen; a[f1].shu=shu-d; break;
                case 'N':a[f1].hen=hen; a[f1].shu=shu+d; break;
                case 'E':a[f1].hen=hen+d; a[f1].shu=shu; break;			 	
              }	
		    }	
		    tt=q[i].time;
  		  }	
  		  int f1=getfa(q[i].s),f2=getfa(q[i].e);
  		  if(f1!=f2) ans[q[i].index]=-1;
  		  else{
  		  	int s=q[i].s,e=q[i].e; 
		    ans[q[i].index]=abs(a[s].hen-a[e].hen)+abs(a[s].shu-a[e].shu);
  		  }
		}
		//rep(i,n) printf("%d %d %d %d\n",i,a[i].fa,a[i].hen,a[i].shu);
		rep(i,k) printf("%d\n",ans[i]);

	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值