A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one repetition of ”abcabcabcabc”). Write a program to read a character string and determine its smallest period.
Input
The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.
Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.
Sample Input
1
HoHoHo
Sample Output
2
题目:要求求一个串的最小循环节。
思路:数量较小,直接暴力枚举,在长度范围之内,一个个枚举周期即可,找到第一组解即为最小(注意所求周期应能被总长度整除)
代码如下:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<ctype.h>
#define N 105
char s[N];
int main()
{
int i,j,k,n,mark=0;
// FILE *f;
// f=freopen("1.in","r",stdin);
// f=freopen("1.out","w",stdout);
scanf("%d",&n);
getchar();
for(i=0;i<n;i++){
memset(s,0,sizeof(s));
scanf("%s",s);
for(j=1;j<=strlen(s);j++){
mark=0;
if(strlen(s)%j==0){
for(k=j;k<strlen(s);k++){
if(s[k-j]!=s[k]){
mark=1;
break;
}
}
if(mark==0){
printf("%d",j);
if(i!=n-1)
printf("\n");
break;
}
}
if(j==strlen(s)){
printf("%d",strlen(s));
if(i!=n-1)
printf("\n");
}
}
printf("\n");
}
return 0;
}