UVa 1152 4 Values whose Sum is 0

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d) ∈ A × B × C × D are such that a + b + c + d = 0. In the following, we assume that all lists have the same size n.

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs. The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228) that belong respectively to A, B, C and D.

Output

For each test case, your program has to write the number quadruplets whose sum is zero. The outputs of two consecutive cases will be separated by a blank line.

Sample Input

1

6

-45 22 42 -16

-41 -27 56 30

-36 53 -37 77

-36 30 -75 -46

26 -38 -10 62

-32 -54 -6 45

Sample Output

5

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46), (-32, 30, -75, 77), (-32, -54, 56, 30).

分析:先枚举A和B,把所有A+B记录下来放在数组中,再枚举C和D,用二分查找-C-D在数组中能否找到。

代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N = 5050;
const int M = 16000005;
long long a[N],b[N];
long long c[N],d[N];
long long sumab[M];
long long sum;
long long ans;
int main(){
    int n,m;
    cin>>n;
    while(n--){
    	cin>>m;
    	for(int i=0;i<m;i++)
    	    cin>>a[i]>>b[i]>>c[i]>>d[i];
    	int k=0;
    	for(int i=0;i<m;i++)
    	    for(int j=0;j<m;j++)
    	         sumab[k++]=a[i]+b[j];
		sum=0;
		ans=0;
		sort(sumab,sumab+k);
		for(int i=0;i<m;i++)
		    for(int j=0;j<m;j++){
		    	sum=c[i]+d[j];
		    	ans+=upper_bound(sumab,sumab+k,-sum)-lower_bound(sumab,sumab+k,-sum);
			}
		printf("%lld\n",ans);
		if(n)
		    printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值