ERROR: torch-1.0.0-cp36-cp36m-linux_x86_64.whl is not a supported wheel on this platform.

代码运行报错:THCudaCheck FAIL file=/pytorch/aten/src/THC/THCGeneral.cpp line=405 error=11 : invalid argument
报错原因:显卡用的RTX 2060,CUDA就要装10以上,这个时候pytorch不能直接用pip装,要这样:

pip install https://download.pytorch.org/whl/cu100/torch-1.0.0-cp36-cp36m-linux_x86_64.whl

不过运行时报错:
ERROR: torch-1.0.0-cp36-cp36m-linux_x86_64.whl is not a supported wheel on this platform.
出现这个问题的原因是版本不匹配
查看本机python的版本匹配哪些文件
解决办法:
在shell下输入:

python

然后输入:
Python3.7下输入

import pip._internal
print(pip._internal.pep425tags.get_supported())

Python 3.6.0下输入:

import pip._internal.pep425tags
print(pip._internal.pep425tags.get_supported())

因为如果按照上面Python3.7的输入会报错:

AttributeError: module 'pip._internal' has no attribute 'pep425tags'

在这里插入图片描述在这里插入图片描述
下载安装对应的版本文件即可
在这里插入图片描述
参考:https://blog.csdn.net/xiuxiuen_michelle/article/details/81080694
https://blog.csdn.net/qq_38161040/article/details/103881372?depth_1-utm_source=distribute.pc_relevant.none-task&utm_source=distribute.pc_relevant.none-task

©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值