POJ1426 Find The Multiple

该博客介绍了如何编写一个程序,寻找一个由0和1组成的非零数字,该数字能被给定的正整数 n 整除。通过广度优先搜索(BFS)策略,从1开始,尝试将0或1添加到当前数字,检查是否满足条件。当找到满足条件的数字时,输出该数字。博客提供了具体的代码实现,包括输入处理、搜索逻辑和递归调用的细节。
摘要由CSDN通过智能技术生成

题目出处:http://poj.org/problem?id=1426

题目描绘

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 64599 Accepted: 26225 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input

2
6
19
0
Sample Output

10
100100100100100100
111111111111111111

题意

给出一个数字找能被它整除并且都是由0或1组成的数。

思路

  1. 前导必须是1.
  2. 可以利用bfs,对所有情况进行一个遍历。
    例如: n = 6 n=6 n=6的时候, 先设 k = 1 k=1 k=1,然后 k k%n k 进行判断,如果等于0则符合直接输出k,如果不等于0则不符合,对后续增加0或1,则 k ∗ 10 k*10 k10 k ∗ 10 + 1 k*10+1 k10+1 ,然后继续对各个情况进行判断直到找到答案为止,这里可以利用bfs进行一个搜索,两个入口 k ∗ 10 k*10 k10 k ∗ 10 + 1 k*10+1 k10+1,直到搜到答案为止,这里利用递归进行一个搜索实现。

代码实现:

#include<iostream>
using namespace std;
typedef unsigned long long ull;
ull ans;
int bfs(ull f,ull e,ull n)
{
    if(f>=e) return 0;   //当f大于e的时候说明该情况不符合题意。

    if(e%n==0)           //符合答案要求,赋值给ans进行输出
    {
        ans=e;b
        return 1;
    }

    if(bfs(e,e*10,n))    //进入e*10的情况进行尝试
    {
        return 1;
    }

    if (bfs(e,e*10+1,n))  //进入e*10+1的情况进行尝试
    {
        return 1;
    }
    return 0;
}
int main()
{
    int t;
    while(1)
    {
        cin>>t;
        if(t==0) break;
        bfs(0,1,t);         //从1开始进行尝试,是否能被t整除
        cout<<ans<<endl;    //输出答案

    }
  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值