HDU:3117 Fibonacci Numbers

Fibonacci Numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 328 Accepted Submission(s): 156

Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.

What is the numerical value of the nth Fibonacci number?

Input
For each test case, a line will contain an integer i between 0 and 108 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“…”).

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).

Sample Input
0
1
2
3
4
5
35
36
37
38
39
40
64
65

Sample Output
0
1
1
2
3
5
9227465
14930352
24157817
39088169
63245986
1023…4155
1061…7723
1716…7565

Source
IPCP 2005 Northern Preliminary for Northeast North-America

Recommend
lcy

/

题目大意:给定一个K(K很大很大),请你输出第K个Fibonacci数的前四位和后四位。

解题思路:这道题一开始后四位我直接就是想着去打表,我只是猜测说后四位的数字可能会形成一个周期,所以我就写了个测试代码,来测试是否存在周期,结果发现果然存在周期15000,所以就打表打出了后四位的值。前四位的求法也是参考了别人的思路后才了解的。

我们要搬出Fibonacci的通项公式——
f(n)=1/sqrt(5)(((1+sqrt(5))/2)^n+((1-sqrt(5))/2)^n)

假设F[n]可以表示成 t * 10^k(t是一个小数),那么对于F[n]取对数log10,答案就为log10 t + K,此时很明显log10 t<1,于是我们去除整数部分,就得到了log10 t ,再用pow(10,log10 t)我们就还原回了t。将t×1000就得到了F[n]的前四位。

具体实现的时候Log10 F[n]约等于((1+sqrt(5))/2)^n/sqrt(5),这里我们把((1-sqrt(5))/2)^n这一项忽略了,因为当N>=40时,这个数已经小的可以忽略。于是log10 F[n]就可以化简成log10 1/sqrt(5) + n*log10 (1+sqrt(5))/2

前四位:公式为:
这个公式只对前40有效 如果N大于40 因为太大数的缘故都变成1了。
于是要另外处理下。即用将刚那个公式记为tt。对tt处理为10^log10(tt)-(int)log10(tt)
将其变为小数。如1234556将被变成1.234556
再取前四位的话再乘以1000即可
如此便可求得前四位

循环周期为15000
可用程序求证

如此得到周期后 用打表即可


<code>

#include<iostream>
#include<math.h>//开始用<cmath>竟然会报错
using namespace std;
int a[15000]={0,1,1};
int main()
{
    int f[50]={0,1,1};
    int i,n;
    int t;
    double ans,tt;
    for(i=3;i<15000;i++)
    a[i]=(a[i-1]+a[i-2])000;
    for(i=3;i<=40;i++)
    f[i]=f[i-1]+f[i-2];
    while(scanf("%d",&n)!=EOF)
    {
         if(n<40)cout<<f[n]<<endl;
         else
         {
            ans=-0.5*(log10(5.0))+n*log10((1+sqrt(5.0))/2);
            ans-=(int)ans;
            ans=pow(10,ans);
            while(ans<1000)
            ans*=10;
            printf("%d...",(int)ans);
            printf("%4.4d\n",a[n000]);
         }
   }return 0;
}
  


本文来自CSDN博客,转载请标明出处:http://blog.csdn.net/bool_isprime/archive/2010/08/07/5794408.aspx

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值