POJ  1753  Flip Game

Flip Game
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 14504Accepted: 6218

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

POJ <wbr> <wbr>1753 <wbr> <wbr>Flip <wbr>GameConsider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

唉,郁闷啊,研究了一整晚加上一整上午才弄出来。
这个题就是用枚举举遍所有情况,然后一个一个深搜看看是不是符合条件,符合条件直接退出,不符合则继续,由于表格只有16个所以可以得知最多的步数只能是16,所以可以根据步数从0到16依次枚举,第一个符合条件的就是最小的步数,为了容易深搜,可以设定顺序为一行一行深搜,当一行搜完时从下一行开头搜,代码和测试数据如下:
#include<stdio.h>
int map[4][4],step,flag=0;
void turn(int i,int j)//转换
{
map[i][j]=!map[i][j];
if(i>0)
map[i-1][j]=!map[i-1][j];
if(i<3)
map[i+1][j]=!map[i+1][j];
if(j>0)
map[i][j-1]=!map[i][j-1];
if(j<3)
map[i][j+1]=!map[i][j+1];
}
int range()//判定表格是否全部一样
{
int i,j;
for(i=0;i<4;i++)
for(j=0;j<4;j++)
if(map[i][j]!=map[0][0])
return 0;
return 1;
}
int DFS(int i,int j,int dp)//深搜
{
if(dp==step){
flag=range();
return 0;
}
if(flag||i==4)return 1;
turn(i,j);
if(j<3)DFS(i,j+1,dp+1);
else DFS(i+1,0,dp+1);
turn(i,j);
if(j<3)DFS(i,j+1,dp);
else DFS(i+1,0,dp);
return 0;
}
int main()
{
int i,j;
char a;
for(i=0;i<4;i++)
{
for(j=0;j<4;j++)
{
scanf("%c",&a);
if(a=='b')map[i][j]=0;
else map[i][j]=1;
}
getchar();
}
for(step=0;step<=16;step++)
{
flag=0;
DFS(0,0,0);
if(flag)break;
}
if(flag)printf("%d\n",step);
else printf("Impossible\n");
return 0;
}

官方测试数据: 这些都过了,就不可能WA了。

bwbw
wwww
bbwb
bwwb
Impossible

bwwb
bbwb
bwwb
bwww
4

wwww
wwww
wwww
wwww
0

bbbb
bbbb
bbbb
bbbb
0

bbbb
bwbb
bbbb
bbbb
Impossible

bwbb
bwbb
bwbb
bbbb
Impossible

bwbb
wwwb
bwbb
bbbb
1

wwww
wwwb
wwbb
wwwb
1

wwww
wwww
wwwb
wwbb
1

wbwb
bwbw
wbwb
bwbw
Impossible

bbbb
bwwb
bwwb
bbbb
4

bwwb
wbbw
wbbw
bwwb
4

bbww
bbww
wwbb
wwbb
Impossible

bbwb
bbbw
wwbb
wwwb
Impossible

wwwb
wwbw
wbww
wwbw
Impossible

bbbb
wwww
wwbb
wbbb
Impossible

bwwb
wbwb
wbbb
wbbb
4

bwbb
bwbb
bwbw
bbbw
5

wbwb
bbbb
bbww
wbbb
6

bbwb
bbbb
wbwb
bbbb
5

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ1753题目为"Flip Game",题目给出了一个4x4的棋盘,每个格子有黑色或白色,每次翻转一个格子会同时翻转它上下左右四个格子的颜色,目标是把整个棋盘都变为同一种颜色,求把棋盘变成同种颜色的最小步数。 解题思路: 一般关于棋盘变色的题目,可以考虑使用搜索来解决。对于POJ1753题目,可以使用广度优先搜索(BFS)来解决。 首先,对于每个格子,定义一个状态,0表示当前格子是白色,1表示当前格子是黑色。 然后,我们可以把棋盘抽象成一个长度为16的二进制数,将所有格子的状态按照从左往右,从上往下的顺序排列,就可以用一个16位的二进制数表示整个棋盘的状态。例如,一个棋盘状态为: 0101 1010 0101 1010 则按照从左往右,从上往下的顺序把所有格子的状态连接起来,即可得到该棋盘的状态为"0101101001011010"。 接着,我们可以使用队列来实现广度优先搜索。首先将初始状态加入队列中,然后对于队列中的每一个状态,我们都尝试将棋盘上的每个格子翻转一次,生成一个新状态,将新状态加入队列中。对于每一个新状态,我们也需要记录它是从哪个状态翻转得到的,以便在得到最终状态时能够输出路径。 在搜索过程中,我们需要维护每个状态离初始状态的步数,即将该状态转换为最终状态需要的最小步数。如果我们找到了最终状态,就可以输出答案,即最小步数。 代码实现:

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值