ZZULI_SummerPractice(5)  ZOJ 185…

Time Limit: 1000MSMemory Limit: 32768K64bit IO Format: %lld & %llu

[Submit  [Go Back  [Status]

Description

Soundex coding groups together words that appear to sound alike based on their spelling. For example, "can" and "khawn", "con" and "gone" would be equivalent under Soundex coding.

Soundex coding involves translating each word into a series of digits in which each digit represents a letter:

1 represents B, F, P, or V
2 represents C, G, J, K, Q, S, X, or Z
3 represents D or T
4 represents L
5 represents M or N
6 represents R

The letters A, E, I, O, U, H, W, and Y are not represented in Soundex coding, and repeated letters with the same code digit are represented by a single instance of that digit. Words with the same Soundex coding are considered equivalent.


Input



Each line of input contains a single word, all upper case, less than 20 letters long.


Output

For each line of input, produce a line of output giving the Soundex code.


Sample Input



KHAWN
PFISTER
BOBBY


Sample Output



25
1236
11
发现这次怎么出这么多字符串处理的题,这题就是讲对应的字母换成数字,注意,挨着相同的转换数字只输出一个就行了,模拟,不解释
#include<stdio.h>
int main()
{
int i,n;
char str[25],s;
while(gets(str))
{
s=0;n=0;
for(i=0;str[i];i++)
{
if(str[i]==s)
continue;
s=str[i];
if(str[i]=='B'||str[i]=='F'||str[i]=='P'||str[i]=='V')
{
if(n!=1)
{printf("1");n=1;}
}
else if(str[i]=='C'||str[i]=='G'||str[i]=='J'||str[i]=='K'||str[i]=='Q'||str[i]=='S'||str[i]=='X'||str[i]=='Z')
{
if(n!=2)
{printf("2");n=2;}
}
else if(str[i]=='D'||str[i]=='T')
{
if(n!=3)
{n=3; printf("3");}
}
else if(str[i]=='L')
{
if(n!=4)
{printf("4");n=4;}
}
else if(str[i]=='M'||str[i]=='N')
{
if(n!=5)
{n=5; printf("5");}
}
else if(str[i]=='R')
{
if(n!=6)
{n=6; printf("6");}
}
else n=0;
}
printf("\n");
}
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值