HDU 1102  Constructing Roads

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)     Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4902     Accepted Submission(s): 1757


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
 

Sample Output
179
 

Source
kicc
 

Recommend
Eddy
典型的最小生成树,这种题原来做过多少遍了,可是还不知道这就叫最小生成树 HDU <wbr>1102 <wbr> <wbr>Constructing <wbr>Roads
先把有效的路径从小到大排序,然后合并村庄,不在一个father节点的说明要合并,加上他的距离,然后合并,最后的距离就是所求的结果啦,嘿嘿,没想到1A
代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct point{
int begin,end,len;
}dist[10000];
int mark[108];
int cmp(const void *a,const void *b)
{
struct point *c,*d;
c=(struct point *)a;
d=(struct point *)b;
return c->len-d->len;
}
int father(int x)
{
if(mark[x]==x)
return x;
mark[x]=father(mark[x]);
return mark[x];
}
int main()
{
int N,i,j,k,Q,a,b,fa,fb,sum;
int flag[108][108];
while(scanf("%d",&N)!=EOF)
{
memset(flag,0,sizeof(flag));
k=0;
for(i=1;i<=N;i++)
for(j=1;j<=N;j++)
{
scanf("%d",&a);
if(i<j){
dist[k].len=a;
dist[k].begin=i;
dist[k++].end=j;
}
}
for(i=0;i<=N;i++)
mark[i]=i;
scanf("%d",&Q);
for(i=0;i<Q;i++)
{
scanf("%d%d",&a,&b);
fa=father(a);
fb=father(b);
if(fa!=fb){
if(fa>fb)
mark[fa]=fb;
else mark[fb]=fa;
}
}
qsort(dist,k,sizeof(dist[0]),cmp);
sum=0;
for(i=0;i<k;i++)
{
fa=father(dist[i].begin);
fb=father(dist[i].end);
if(fa!=fb){
sum+=dist[i].len;
if(fa>fb)
mark[fa]=fb;
else mark[fb]=fa;
}
}
printf("%d\n",sum);
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值