ZZULI_SUMMER_PRACTICE(8)  ZOJ 23…

Time Limit: 1000MSMemory Limit: 32768KB64bit IO Format: %lld & %llu

[Submit  [Go Back  [Status]

Description

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.


Input

Only one town will be given in an input.

  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house's owner. Each name consists of up to 20 characters {a�Cz,A�CZ,0�C9} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form
    <house name A> <house name B> <distance>
    Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

Output

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output

Not enough cable

If there is enough cable, then output

Need <X> miles of cable

Print X to the nearest tenth of a mile (0.1).


Sample Input

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0


Sample Output

Need 10.2 miles of cable

代码:

C语言临时自用代码
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct  point {
        int  x , y;
        double  lenth;
} map [ 1000008 ];
int  flag [ 1008 ];
int  cmp( const  void  * a , const  void  *b)
{
        struct  point  * c , * d;
        c =( struct  point  *) a;
        d =( struct  point  *)b;
        return  c -> lenth > d -> lenth ? 1 :- 1;
}
int  father( int  x)
{
        if( x == flag [ x ])
                return  x;
        flag [ x ] = father( flag [ x ]);
        return  flag [ x ];
}
int  main()
{
        int  n , m , i , j , k , a ,b;
        char  str [ 1008 ][ 25 ], str1 [ 25 ], str2 [ 25 ];
        double  Long , sum;
        scanf( "%lf" , & Long);
        scanf( "%d" , &n);
        for( i = 0; i <n; i ++)
        {
                scanf( "%s" , str [ i ]);
                flag [ i ] = i;
        }
        scanf( "%d" , & m);
        k = 0;
        for( i = 0; i < m; i ++)
        {
                scanf( "%s %s %lf" , str1 , str2 , & sum);
                for( j = 0; j <n; j ++)
                        if( strcmp( str1 , str [ j ]) == 0)
                                break;
                if( j <n) a = j;
                for( j = 0; j <n; j ++)
                        if( strcmp( str2 , str [ j ]) == 0)
                                break;
                if( j <n)b = j;
                map [ k ]. x = a;
                map [ k ]. y =b;
                map [ k ++ ]. lenth = sum;
        }
        qsort( map , k , sizeof( map [ 0 ]), cmp);
        sum = 0;
        for( i = 0; i < k; i ++)
        {
                a = father( map [ i ]. x);
              b = father( map [ i ]. y);
                if( a !=b ){
                        if( a >b)
                                flag [ a ] =b;
                        else  flag [b ] = a;
                        sum += map [ i ]. lenth;
                }
                if( sum > Long) break;
        }
        if( i < k) printf( "Not enough cable \n ");
        else  printf( "Need %.1lf miles of cable \n " , sum);
        return  0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值