ZOJ 1048  Gridland(水水更健康!*…

Gridland

Time Limit: 2 Seconds         Memory Limit: 65536 KB

Background

For years, computer scientists have been trying to find efficient solutions to different computing problems. For some of them efficient algorithms are already available, these are the "easy" problems like sorting, evaluating a polynomial or finding the shortest path in a graph. For the "hard" ones only exponential-time algorithms are known. The traveling-salesman problem belongs to this latter group. Given a set of N towns and roads between these towns, the problem is to compute the shortest path allowing a salesman to visit each of the towns once and only once and return to the starting point.


Problem

The president of Gridland has hired you to design a program that calculates the length of the shortest traveling-salesman tour for the towns in the country. In Gridland, there is one town at each of the points of a rectangular grid. Roads run from every town in the directions North, Northwest, West, Southwest, South, Southeast, East, and Northeast, provided that there is a neighbouring town in that direction. The distance between neighbouring towns in directions North-South or East-West is 1 unit. The length of the roads is measured by the Euclidean distance. For example, Figure 7 shows 2 * 3-Gridland, i.e., a rectangular grid of dimensions 2 by 3. In 2 * 3-Gridland, the shortest tour has length 6.

ZOJ <wbr>1048 <wbr> <wbr>Gridland(水水更健康!*_*)
Figure 7: A traveling-salesman tour in 2 * 3-Gridland.

Input

The first line contains the number of scenarios.

For each scenario, the grid dimensions m and n will be given as two integer numbers in a single line, separated by a single blank, satisfying 1 < m < 50 and 1 < n < 50.


Output

The output for each scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. In the next line, print the length of the shortest traveling-salesman tour rounded to two decimal digits. The output for every scenario ends with a blank line.


Sample Input

2
2 2
2 3


Sample Output

Scenario #1:
4.00

Scenario #2:
6.00

 

水题一枚,简单介绍一下题意:给你一个m*n的矩阵,矩阵上的相邻两点之间有直线相连,也可以通过对角线到达,要求找出最短可以转一圈遍历所有点回到原点的路径长度。

 

m和n都为奇数时,路径长度为m*n-1+2的开平方,有一个为偶数时路径长度为m*n。

 

代码:

 

#include<stdio.h>
#include<math.h>
int main()
{
        int Case,m,n,i;
        scanf("%d",&Case);
        for(i=1;i<=Case;i++)
        {
                scanf("%d%d",&m,&n);
                printf("Scenario #%d:\n",i);
                if(m%2!=0&&n%2!=0)
                        printf("%.2lf\n",(m*n-1+sqrt(2)));
                else printf("%.2lf\n",(double)m*n);
                printf("\n");
        }
        return 0;
}
 
PS:本来想用Java写的,可是最后的时候不会怎么保留两位小数……
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值