ZOJ 1041(POJ 1106) Transmitters(…

Transmitters

Time Limit: 2 Seconds         Memory Limit: 65536 KB

In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don't overlap, or at least that they don't conflict. One way of accomplishing this is to restrict a transmitter's coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle.

A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can be simultaneously reached by the transmitter's signal. Figure 1 shows the same data points with two different transmitter rotations.

ZOJ <wbr>1041(POJ <wbr>1106) <wbr>Transmitters(计算几何水过鈥︹) <wbr>狗狗四十题

All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same location as the transmitter.

Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains the number of points N on the grid, followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the first two example data sets below, though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.

For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle.

Example input:

25 25 3.5
7
25 28
23 27
27 27
24 23
26 23
24 29
26 29
350 200 2.0
5
350 202
350 199
350 198
348 200
352 200
995 995 10.0
4
1000 1000
999 998
990 992
1000 999
100 100 -2.5


Example output:

3
4
4


Source: Mid-Central USA 2001

 

今天状态不错,做题挺顺利的,小得瑟一下(还是心情好啊,心情好,做嘛嘛对……)

 

水题一枚,先说题意:给一个圆的坐标和半径(其实是半圆了……),这个半圆可以沿着圆心转动,然后给你n多个点,这些点位置随机,当半圆转动的时候一些点会在半圆的内部或者半圆边缘上,求半圆在某一个状态可以包括的最多的点为几个……

 

先把圆可以包含的点选出来(如果圆不论如何都不能转动的话,不考虑,直接Pass),然后以此遍历这些点,假设该点正好在边缘上,计算出直径两边的点各有多少,这样的话就可以求出最多的点了。

 

好郁闷,用C++写的时候竟然一直的CE,泪奔啊,在POJ上提交就没事……  (难道真的和传说中的人品有关??)

 

代码:

#include<stdio.h>
#include<math.h>
int n;
double point_x , point_y , point_r;
struct node {
      double x , y;
} map [ 155 ];

double distance( double a , double b) //求点与圆心的距离
{
      return sqrt(( point_x - a) *( point_x - a) +( point_y -b) *( point_y -b));
}

double mul( int a , int b) //求两点与圆心构成的向量叉积
{
      double x1 , x2 , y1 , y2;
      x1 = map [ a ]. x - point_x;
      y1 = map [ a ]. y - point_y;
      x2 = map [b ]. x - point_x;
      y2 = map [b ]. y - point_y;
      return ( x1 * y2) -( x2 * y1);
}
int main()
{
      int i , j , len , max;
      double m , a ,b;
      while( scanf( "%lf%lf%lf" , & point_x , & point_y , & point_r ), point_r >= 0)
      {
              scanf( "%d" , &n);
              j = 0;
              for( i = 0; i <n; i ++)
              {
                      scanf( "%lf%lf" , & a , &b);
                      m = distance( a ,b);
                      if( m < point_r||( m - point_r) < 1e-10)
                      {
                              map [ j ]. x = a;
                              map [ j ++ ]. y =b;
                      }
              }
              len = j; max = 0;
              for( i = 0; i < len; i ++)
              {
                      a =b = 0;
                      for( j = 0; j < len; j ++)
                      {
                              m = mul( i , j);
                              if( m > 0)
                                      a ++;
                              else if( m < 0)b ++;
                              else { a ++;b ++ ;}
                      }
                      if( max < a)
                              max =( int) a;
                      if( max <b)
                              max =( int)b;
              }
              printf( "%d \n " , max);
      }
      return 0;
}
 
PS:当点在直径上的时候要记得两边都要加哦,因为可以认为属于任意两边的

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值