二分贪心专题B

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2). 
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces. 
Output
The output should contain the minimum setup time in minutes, one per line. 
Sample Input
3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2

1

3

题目大意:有一堆待加工的木棒,木棒有属性长度L和质量W,我们对木棒加工有准备时间,规则如下:

1.第一根木棒花费准备时间1min

2.加工长度与质量均比上一根大的不需要准备时间,反之需要花费1min

要求求最小的准备时间。

按照题意分析,我们将L与W看做两个数列,两个数列递增则不需要准备时间。即有几个这样双递增的数列就需要花费几分钟准备时间。

首先我们先找一个单递增的数列(L或者W) 这里我们以L为关键字进行排序。L相同的情况下按照W从小到大排序。

现在L已经是单调递增数列。我们从头遍历,找有几个单增的W数列(方法很简单就是有一个变量记录上一个木棒的W属性,对于当前访问的木棒i,若Wi<W,则是一个新的数列,否则continue)。添加标记数组v,已加工的木棒标为true。 


源代码:

#include<iostream>
#include<algorithm>
using namespace std;

struct mytype
{
	int length;
	int weight;
	bool vis;
};

int mycompare(mytype a,mytype b)
{
	if (a.length==b.length) return a.weight<b.weight;
	return a.length<b.length;
}

int main()
{
	int k;
	cin>>k;
	for (int o=1;o<=k;o++)
	{
		int n;
		mytype a[5010];
		cin>>n;
		for (int i=1;i<=n;i++) a[i].vis=false;
		for (int i=1;i<=n;i++) cin>>a[i].length>>a[i].weight;
		sort(a+1,a+n+1,mycompare);
		int ans=0;int wei;
		for (int i=1;i<=n;i++)
		{
			if (a[i].vis) continue;
			if (!a[i].vis)
			{
				ans++;
				a[i].vis=true;
				wei=a[i].weight;
			}
			for (int j=i+1;j<=n;j++)
			{
				if (a[j].vis) continue;
				if (!a[j].vis&&a[j].weight<wei) continue;
				if (!a[j].vis&&a[j].weight>=wei)
				{
					a[j].vis=true;
					wei=a[j].weight;
					continue;
				}
			}
		}
		cout<<ans<<endl;	
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
二分贪心算法和浙江工业大学之间似乎没有直接的关联。二分贪心算法是一种综合了二分贪心思想的算法,用于在解决问题时对数据进行二分划分,并在每一步选择中采取最优的贪心策略。而浙江工业大学是一所位于中国浙江省的工科大学。 引用和中提到的贪心算法是一种在问题求解中每一步都选择最优的策略,但得到的结果不一定是最优解,但是通常是相对近似最优解的结果。这种算法在某种意义上是局部最优解。 引用中提到的Dijkstra算法是一种基于贪心和广度优先搜索的算法,用于求解图中一个点到其他所有点的最短路径。该算法的时间复杂度为O(n^2)。 从以上内容来看,二分贪心算法和浙江工业大学之间并没有明显的联系。可能是问题描述不完整或者存在其他相关信息,导致无法直接回答与贪心算法和浙江工业大学有关的问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [常用十大算法 非递归二分查找、分治法、动态规划、贪心算法、回溯算法(骑士周游为例)、KMP、最小生成树算法...](https://blog.csdn.net/lonelysnowman/article/details/127493659)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* [6.二分+贪心](https://blog.csdn.net/qq_52008247/article/details/119151264)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值