Single Round Match

12 篇文章 0 订阅

Problem Description

Association for Couples Match (ACM) is a non-profit organization which is engaged in helping single people to find his/her other half. As November 11th is "Singles Day", on this day, ACM invites a large group of singles to the party. People round together, chatting with others, and matching partners. There are N gentlemen and M ladies in the party, each gentleman should only match with a lady and vice versa. To memorize the Singles Day, ACM decides to divide people into 11 groups, each group should have the same amount of couples and no people are left without the groups. Can ACM achieve the goal?

Input

The first line of the input is a positive integer T. T is the number of test cases followed. Each test case contains two integer N and M (0<=N, M<=101000), which are the amount of gentlemen and ladies. It is worth notice that N and M are really huge. You are suggested to input the number with string.

Output

For each test case, output “YES” if it is possible to find a way, output “NO” if not.

Sample Input

3
1 1
11 11
22 11

Sample Output

NO
YES
NO
 
#include<iostream>
#include<string>
#include<cstdio>
using namespace std;
int main()
{
    __int64 n = 0, m = 0;
    int i, t;
    string a, b;
    while(cin >> t)
    {
        while(t--)
        {
            cin >> a >> b;
            n = 0;
            if(a == b)
            {
                for(i = 0; a[i]; i++)
                    n = (n * 10 + (a[i] - '0')) % 11;
                if(n == 0)  cout << "YES" << endl;
                else cout << "NO" << endl;
            }
            else cout << "NO" << endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值