1061 Dating (20 分)

Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
Sample Output:
THU 14:04
//主要是读题上
case sensitive 区分大小写的

the first common capital english letter
第一个普通大写英文字母

星期:第一个字符串和第二个字符串相同位置上并且>=‘A’ && <= 'G’对应输出

小时:第一个字符串和第二个字符串相同位置上 在上一个星期查找之后 是0—9 || A–N 之间输出

分钟:第三个字符串和第四个字符串相同位置上 相同位置输出i 不分大小写

总结:pat20分不要想得太复杂,要是读不懂题怎末简单怎末理解!

isalpha()函数:一种函数:判断字符ch是否为英文字母,若为英文字母,返回非0(小写字母为2,大写字母为1)。若不是字母,返回0。在标准c中相当于使用" isupper( ch ) || islower( ch ) "做测试。

代码来自

#include<bits/stdc++.h>
using namespace std;
map<char,string>mp;
void init()
{
	mp['A'] = "MON";mp['B'] = "TUE";
	mp['C'] = "WED";mp['D'] = "THU";
	mp['E'] = "FRI";mp['F'] = "SAT";
	mp['G'] = "SUN";
}
int main()
{
	string s1,s2,s3,s4;
	cin>>s1>>s2>>s3>>s4;
	init();
	int minn = min(s1.length(),s2.length()),i;
	for(i = 0; i < minn ;i++)
	{
		if(s1[i] == s2[i] && s1[i] >='A' && s1[i] <= 'G')
		{
			cout<<mp[s1[i]];
			break;
		}
	}
	for(++i; i < minn;i++)
	{
		if(s1[i] == s2[i])
		{
			if(s1[i] >= 'A' && s1[i] <= 'N')
			{
				printf(" %02d:",(10+s1[i]-'A'));
				break;
			}	
			else if(isdigit(s1[i]))
			{
				printf(" %02d:",s1[i]-'0');
				break;
			}	
		}
	}
	minn = min(s3.length(),s4.length());
	for(int i = 0; i< minn ;i++)
	{
		if(s3[i] == s4[i] && isalpha(s3[i]))
		{
			printf("%02d\n",i);
			return 0;
		}	
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值