PAT 1065 A+B and C (64bit) (20)

1065 A+B and C (64bit) (20)(20 分)

Given three integers A, B and C in [-2^63^, 2^63^], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B&gtC, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

思路:

关键在于如何判断溢出时的a+b>c,这需要一点小技巧了。LLONG_MAX和LLONG_MIN是longlong类型的最大范围和最小范围,在limits.h文件里面。上溢就是a+b>LLONG_MAX的情况,如果直接a+b算的话就溢出了,改成a>LLONG_MAX-b就可以了,下溢也是同理。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

bool compare(long long a, long long b, long long c)
{
	if (a > 0 && b > 0 && a > LLONG_MAX - b)
		return true;
	if (a < 0 && b < 0 && a < LLONG_MIN - b)
		return false;
	return a + b > c;
}

int main()
{
	int n;
	long long a, b, c;
	cin>>n;
	for (int i = 1; i <= n; i++)
	{
		cin >> a >> b >> c;
		cout << "Case #" << i << ": ";
		if (compare(a,b,c))
			cout << "true" << endl;
		else
			cout << "false" << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值