PAT 1096 Consecutive Factors (20)

1096 Consecutive Factors (20)(20 分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2^31).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

思路:

因为1不算,所以因子从2开始找起。我们可以缩小一点规模,不需要循环到n,到sqrt(n)即可,因为这样正好是乘法的一半(假如一个因子是i,那么与之对应的另一个就是n/i,i*i=n可以得到i最大为sqrt(n))。当找到一个因子可以整除的时候,就看它后面连续的数是否可以当做因子继续整除。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

int main()
{
	int n;
	cin >> n;
	int maxn = 0, start = n, temp, k, cnt;
	for (int i = 2; i <= sqrt(n); i++)
	{
		temp = n;
		k = i;
		cnt = 0;
		while (temp%k == 0)
		{
			cnt++;
			temp /= k;
			k++;
		}
		if (cnt > maxn)
		{
			maxn = cnt;
			start = i;
		}
	}
	if (maxn == 0)
		maxn = 1;
	cout << maxn << endl;
	for (int i = 0; i < maxn - 1; i++)
		cout << start + i << "*";
	cout << start + maxn - 1 << endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值