PAT 1002 A+B for Polynomials (25)

11 篇文章 0 订阅
5 篇文章 0 订阅

1002 A+B for Polynomials (25)(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

where K is the number of nonzero terms in the polynomial, Ni and aNi​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

思路:

用map来求多项式的各项和,用set来记录出现的项,需要注意的是有的项相加会变成0,此时这些项应删去。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

struct compare
{
	bool operator()(int a, int b)
	{
		return a > b;
	}
};

int main()
{
	map<int,double> poly;
	set<int, compare> terms;
	int k, n, cnt = 0;
	double a;
	for (int i = 0; i < 2; i++)
	{
		cin >> k;
		for (int j = 0; j < k; j++)
		{
			cin >> n >> a;
			poly[n] += a;
			if (poly[n] == 0)
				cnt++;
			terms.insert(n);
		}
	}
	cout << terms.size() - cnt;
	for (set<int, compare>::iterator iter = terms.begin(); iter != terms.end(); iter++)
	{
		int t = *iter;
		if(poly[t]!=0)
			printf(" %d %.1lf", t, poly[t]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值