The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.
Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 11. Say froot=1froot=1.
And for each node uu, labels as fufu, the left child is fu×2fu×2 and right child is fu×2+1fu×2+1. The king looks at his tree kingdom, and feels satisfied.
Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another NN years, only if he could collect exactly NN soul gems.
Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node xx, the number at the node is fxfx (remember froot=1froot=1), he can choose to increase his number of soul gem by fxfx, or decrease it by fxfx.
He will walk from the root, visit exactly KK nodes (including the root), and do the increasement or decreasement as told. If at last the number is NN, then he will succeed.
Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.
Given NN, KK, help the King find a way to collect exactly NN soul gems by visiting exactly KK nodes.
Input
First line contains an integer TT, which indicates the number of test cases.
Every test case contains two integers NN and KK, which indicates soul gems the frog king want to collect and number of nodes he can visit.
⋅⋅ 1≤T≤1001≤T≤100.
⋅⋅ ≤N≤1091≤N≤109.
⋅⋅ N≤2K≤260N≤2K≤260.
Output
For every test case, you should output " Case #x:" first, where xx indicates the case number and counts from 11.
Then KK lines follows, each line is formated as ‘a b’, where aa is node label of the node the frog visited, and bb is either ‘+’ or ‘-’ which means he increases / decreases his number by aa.
It’s guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.
Sample Input
2
5 3
10 4
Sample Output
Case #1:
1 +
3 -
7 +
Case #2:
1 +
3 +
6 -
12 +
题意:给你一个n和k和一颗完全二叉树(权值1 2 3 4 5 6 …),让你从1开始一直到第k层选择一条路径,路径上的每个点可以选择1或(-1),让你输出一种构造方案恰好到第n曾能得到n,
因为题目给了N的限制,所以只要用最左面一列就能构造出所有奇数的情况,偶数的时候只要把最左下的节点往右移一个然后n–就可以按奇数的做了
期数的情况下从最左下开始,一直往上减,直到小于0就加,一直循环到1
#include<bits/stdc++.h>
using namespace std;
#define ll long long
ll qpow(ll a,ll b)
{
ll ans=1;
while(b)
{
if(b&1) ans*=a;
b>>=1;
a*=a;
}
return ans;
}
ll n,k,T,cas = 0,fl,vis[100005],ans[10005],cnt;
int main()
{
cin>>T;
while(T--){
fl=1,cnt=0;
cout<<"Case #"<<++cas<<":"<<endl;
cin>>n>>k;
if(n%2==0)
fl=0,n--;
for(int i=k-1;i>=0;i--)
if(n>0)
n-=qpow(2,i),ans[cnt]=qpow(2,i),vis[cnt++]=1;
else
n+=qpow(2,i),ans[cnt]=qpow(2,i),vis[cnt++]=0;
if(!fl)ans[0]++;
for(int i=k-1;i>=0;i--)
printf("%lld %c\n",ans[i],vis[i]?'+':'-');
}
return 0;
}