A Simple Problem with Integers(线段树+懒惰标记模板)

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

整理一下线段树懒惰标记的模板

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=1e6+100;
const int inf=0x3f3f3f3f;
typedef long long ll;
ll sum[maxn*2],lazy[maxn*4],len[maxn*4];
void push(int i)
{
    sum[i]=sum[i*2]+sum[i*2+1];
}
void build(int root,int l,int r)
{
    len[root]=r-l+1;
    if(l==r)
    {
        cin>>sum[root];
        return ;
    }
    int mid=(l+r)/2;
    build(root*2,l,mid);
    build(root*2+1,mid+1,r);
    push(root);
}
void pushdown(int id)
{
    if(lazy[id])
    {
        lazy[id*2]+=lazy[id];
        lazy[id*2+1]+=lazy[id];

        sum[id*2]+=lazy[id]*len[id*2];
        sum[id*2+1]+=lazy[id]*len[id*2+1];
        lazy[id]=0;

    }
}
ll qu(int id,int l,int r,int ql,int qr)
{
    if(ql<=l&&qr>=r)
    {
        return sum[id];
    }
    pushdown(id);
    int mid=(l+r)/2;
    ll ans=0;
    if(ql<=mid)ans+=qu(id*2,l,mid,ql,qr);
    if(qr>mid)ans+=qu(id*2+1,mid+1,r,ql,qr);

    return ans;
}
void up(int id,int l,int r,int ql,int qr,ll val)
{
    if(ql<=l&&qr>=r)
    {
        lazy[id]+=val;
        sum[id]+=val*len[id];
        return ;
    }
    pushdown(id);
    int mid=(l+r)/2;
    if(ql<=mid)up(id*2,l,mid,ql,qr,val);
    if(qr>mid)up(id*2+1,mid+1,r,ql,qr,val);
    push(id);
}
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        build(1,1,n);

        char ch;
        for(int i=1;i<=m;i++)
        {
            cin>>ch;
            if(ch=='Q')
            {
                int x,y;
				scanf("%d%d",&x,&y);
				cout<<qu(1,1,n,x,y)<<endl;

            }
            else{
                int x,y;
				ll z;
				cin>>x>>y>>z;
				up(1,1,n,x,y,z);

            }
        }
    }

}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值