HDU 1213 How Many Tables(并查集,简单)

C - How Many Tables
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 
 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases. 
 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 
 

Sample Input

     
     
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output

     
     
2 4
 

题解:1 2,2 3,4 5,是朋友,所以可以坐一起,求最小的桌子数,那就是2个,因为1 2 3坐一桌,4 5坐一桌。简单的并查集应用,但注意题意是从1到n的,所以要减1。

代码:

#include <map>
#include <set>
#include <list>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <cstdio>
#include <string>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const int INF=0x3f3f3f3f;
typedef long long ll;
typedef unsigned long long ull;
#define prN printf("\n")
#define SI(N) scanf("%d",&(N))
#define SII(N,M) scanf("%d%d",&(N),&(M))
#define SIII(N,M,K) scanf("%d%d%d",&(N),&(M),&(K))
#define cle(a,val) memset(a,(val),sizeof(a))
#define rep(i,b) for(int i=0;i<(b);i++)
#define Rep(i,a,b) for(int i=(a);i<(b);i++)
#define rank mrank
const int MAX_BN=1005;
int par[MAX_BN];// father
int rank[MAX_BN],n,m;// deep

void init(int n)
{
    for (int i=0;i<n;i++)
    {
        par[i]=i;
        rank[i]=0;//并查集是从0开始的  高度也是从0开始的
    }
}
//查询树的根
int myFind(int x)
{
    if (par[x]==x)
    {
        return x;
    }
    else{
        return par[x]=myFind(par[x]);
    }
}
//合并x和y所属的集合
void unite(int x,int y)
{
    x=myFind(x);
    y=myFind(y);
    if (x==y)
        return;

    if (rank[x]<rank[y])
    {
        par[x]=y;
    }
    else
    {
        par[y]=x;
        if (rank[x]==rank[y]) rank[x]++;
    }
}
//判断x和y是否属于同一集合
bool same(int x,int y)
{
    return myFind(x)==myFind(y);
}
int a,b;
int main()
{
#ifndef ONLINE_JUDGE
    freopen("C:\\Users\\Zmy\\Desktop\\in.txt","r",stdin);
//    freopen("C:\\Users\\Zmy\\Desktop\\out.txt","w",stdout);
#endif // ONLINE_JUDGE
    int o;
    SI(o);
    while(o--)
    {
        SII(n,m);
        init(n);
        rep(i,m)
        {
            SII(a,b);
            unite(a-1,b-1);
        }
        int ans=0;
        rep(i,n)
        if (par[i]==i)
            ans++;
        cout<<ans<<endl;
    }
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值