A Chess Game

Submit Status

Description

Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again.

Do you want to challenge me? Just write your program to show your qualification!

 

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

 

Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

 

Sample Input

 

4 2 1 2 0 1 3 0 1 0 2 0 2 0 4 1 1 1 2 0 0 2 0 1 2 1 1 3 0 1 3 0

 

Sample Output

 

WIN WIN WIN LOSE WIN

题目大意:给定一个拓扑图,给定棋子位置,两人移动棋子,棋子无处可移为输。问先手是否必赢。 

#include<stdio.h>
#include<vector>
#include<string.h>
using namespace std;
int n;
vector<int>G[1005];
int sg[1005];

int get_sg(int x)
{
	if(sg[x]!=-1)
	return sg[x];
	else
	{
		int Hash[1005];//千万不要把数组开到外面,每次递归调用时都是一个新的hash
		memset(Hash,0,sizeof(Hash));
		for(int i=0;i<G[x].size();i++)
		{
			Hash[get_sg(G[x][i])]=1;
		}
		int j=0;
		for(;j<n;j++)
		{
			if(Hash[j]!=1)
			break;
		}
		sg[x]=j;
		return j;
	}

}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0;i<n;i++)
		{
			G[i].clear();
		}
		memset(sg,-1,sizeof(sg));
		for(int i=0;i<n;i++)
		{
			int k;
			scanf("%d",&k);
			if(k==0)
			{
				sg[i]=0;
			}
			else{
				for(int j=0;j<k;j++)
				{
					int x;
					scanf("%d",&x);
					G[i].push_back(x);
				}
			}
		}
		int m;
		while(scanf("%d",&m)!=EOF&&m!=0)
		{
			int sum=0;
			for(int i=1;i<=m;i++)
			{
				int q;
				scanf("%d",&q);
				sum=sum^get_sg(q);
			}
			if(sum==0)
			printf("LOSE\n");
			else
			printf("WIN\n");
		}
	}
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,请看下面修改后的代码: ```python from tkinter import * import tkinter.messagebox class ChessBoard: def __init__(self, master=None): self.master = master self.master.title('五子棋') self.master.geometry('450x450') self.color = ['black', 'white'] self.chess_color = 0 self.chessboard = Canvas(self.master, width=450, height=450, bg='#F5DEB3') self.chessboard.pack() for i in range(15): self.chessboard.create_line(15 + 30 * i, 15, 15 + 30 * i, 435, width=2) self.chessboard.create_line(15, 15 + 30 * i, 435, 15 + 30 * i, width=2) self.chessboard.bind('<Button-1>', self.chess_board_click) self.chess = {} self.over = False def chess_board_click(self, event): if self.over: return x, y = event.x, event.y col, row = x // 30, y // 30 if (col, row) in self.chess: return self.draw_chess(col, row) def draw_chess(self, col, row): if self.over: return x, y = 15 + col * 30, 15 + row * 30 color = self.color[self.chess_color] self.chessboard.create_oval(x - 13, y - 13, x + 13, y + 13, fill=color) self.chess[(col, row)] = color self.check_game_over(col, row) self.chess_color = 1 - self.chess_color def check_game_over(self, col, row): directions = [(0, 1), (1, 0), (1, 1), (1, -1)] for direction in directions: count = 1 for i in range(1, 5): col_i, row_i = col + i * direction[0], row + i * direction[1] if (col_i, row_i) in self.chess and self.chess[(col_i, row_i)] == self.color[self.chess_color]: count += 1 else: break for i in range(1, 5): col_i, row_i = col - i * direction[0], row - i * direction[1] if (col_i, row_i) in self.chess and self.chess[(col_i, row_i)] == self.color[self.chess_color]: count += 1 else: break if count >= 5: self.game_over() def game_over(self): self.over = True color = self.color[self.chess_color] tkinter.messagebox.showinfo('五子棋', f'{color}方胜!') if __name__ == '__main__': root = Tk() ChessBoard(root) root.mainloop() ``` 主要的修改如下: 1. 第 65 行的缩进问题已经解决。 2. 第 66 行的 `break` 语句需要放在一个循环中,因此我将其放在了两个 `for` 循环中的一个内部循环中。 希望这次修改能够解决你的问题。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值