Aggressive cows

二分搜索: 

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended

二分搜索: 

#include<stdio.h>
#include<algorithm>
using namespace std;
int n,m;	
int x[100005];
bool ok(int maxv)
{
	int cur=0;
	for(int i=1;i<m;i++)
	{
		int j;
		for( j=cur;j<n;j++)
		{
			if(x[j]-x[cur]>=maxv)
			{
				cur=j;
				break;
			}	
		}
		if(j==n)//由于此时i<m,即对于该距离找不到足够的棚,说明距离大了;
		{
			return false;
		}
	}
	return true;//前面没有退出说明距离可满足;
}
int main()
{

	scanf("%d%d",&n,&m);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&x[i]);
	}
	sort(x,x+n);
	int d=x[n-1]-x[0];
	int l=0;
	int r=d;
	while(r-l>1)//二分搜索找到要求的距离 
	{
		int mid=(r+l)/2;
		if(ok(mid)){
			l=mid;
		}
		else//如果找不到缩小 
		r=mid; 
	}
	printf("%d",l);
 } 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值