数据结构之链表五:单链表的拆分

 

Problem Description

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

Input

第一行输入整数N;;
第二行依次输入N个整数。

Output

第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

Example Input

10
1 3 22 8 15 999 9 44 6 1001

Example Output

4 6
22 8 44 6 
1 3 15 999 9 1001

 

 

 

#include <stdio.h>

#include <stdlib.h>

struct node
{
    int data;
    struct node *next;
};
int main()
{
    int i, n, j, k;
    scanf("%d", &n);
    struct node *head, *tail, *p;
    head = (struct node *)malloc(sizeof(struct node));
    head -> next = NULL;
    tail = head;
    for(i = 0; i < n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p -> data);
        p -> next = NULL;
        tail -> next = p;
        tail = p;
    }
    j = k = 0;
    struct node *head1, *q1, *q;
    head1 = (struct node *)malloc(sizeof(struct node));
    head1 -> next = NULL;
    q1 = head1;
    p = head -> next;
    head -> next = NULL;
    q = p -> next;
    tail = head;
    while(p != NULL)
    {
        if((p -> data) % 2 == 0)
        {
            j++;
            p -> next = NULL;
            q1 -> next = p;
            q1 = p;
        }
        else
        {
            k++;
            p -> next = NULL;
            tail -> next = p;
            tail = p;
        }
        p = q;
        if(q != NULL)
        {
            q = q -> next;
        }
    }
    printf("%d %d\n", j, k);
    tail = head1 -> next;
    while(tail != NULL)
    {
        printf("%d", tail -> data);
        if(tail -> next != NULL)
        {
            printf(" ");
        }
        else
            printf("\n");
        tail = tail -> next;
    }
    tail = head -> next;
    while(tail != NULL)
    {
        printf("%d", tail -> data);
        if(tail -> next != NULL)
        {
            printf(" ");
        }
        else
            printf("\n");
        tail = tail -> next;
    }
    return 0;
}*/
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值