Problem Description
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
Input
第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。
Output
第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
Example Input
10
21 30 14 55 32 63 11 30 55 30
Example Output
10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
#include <stdio.h>
#include <stdlib.h>
struct node
{
int data;
struct node *next;
};
int main()
{
int n, i;
scanf("%d", &n);
struct node *head, *tail, *p, *q, *t;
head = (struct node *)malloc(sizeof(struct node));
head -> next = NULL;
tail = head;
for(i = 0; i < n; i++)
{
p = (struct node *)malloc(sizeof(struct node));
scanf("%d", &p -> data);
p -> next = head -> next;
head -> next = p;
}
printf("%d\n", n);
tail = head -> next;
while(tail != NULL)
{
printf("%d", tail -> data);
if(tail -> next != NULL)
{
printf(" ");
}
else
printf("\n");
tail = tail -> next;
}
p = head -> next;
q = p -> next;
while(p != NULL)
{
q = p -> next;
t = p; //t表示前驱结点
while(q != NULL)
{
if(p -> data == q -> data)
{
n--;
t -> next = q -> next;
free(q);
q = t -> next;
}
t = t -> next;
q = q -> next;
}
p = p-> next;
}
printf("%d\n", n);
tail = head -> next;
while(tail != NULL)
{
printf("%d", tail -> data);
if(tail -> next != NULL)
{
printf(" ");
}
else
printf("\n");
tail = tail -> next;
}
return 0;
}