hdu 5724 Chess(sg博弈)

Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2395    Accepted Submission(s): 1012



Problem Description
Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.
 

Input
Multiple test cases.

The first line contains an integer T(T100) , indicates the number of test cases.

For each test case, the first line contains a single integer n(n1000) , the number of lines of chessboard.

Then n lines, the first integer of ith line is m(m20) , indicates the number of chesses on the ith line of the chessboard. Then m integers pj(1pj20) followed, the position of each chess.
 

Output
For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.
 

Sample Input
  
  
2 1 2 19 20 2 1 19 1 18
 

Sample Output
  
  
NO YES
 

题意:n*20的棋格,每一行放若干个棋子,每个棋子每次只能走一个(若碰到相邻的棋子便跳过),问胜负;

思路:典型的sg博弈,将一行的棋子的必胜态和必输态都列出来,最后异或一下就好。

一些小问题:1.每一行·只有20格,这种很容易想到状压(碰到小于等于20的都应该往状压的方面想一下)。
                         2.memset的用时还是挺大的,当用在循环里时容易超时。


代码:
#include<bits/stdc++.h>
using namespace std;
const int maxn=1<<21;
int num[maxn],sg[maxn];
int  ha[21];
int make_sg(int stat)
{
    memset(ha,-1,sizeof(ha));
    for(int i=20; i>=0; i--)
        if(stat&(1<<i))
        {
            for(int j=i-1; j>=0; j--)
                if(!(stat&(1<<j)))
                {
                    int kk=stat^(1<<i)^(1<<j);
                    ha[sg[kk]]=1;
                    break;
                }
        }
    for(int i=0; i<=20; i++)
        if(ha[i]==-1)
            return i;
    return 0;
}
int main()
{
    int T;
    scanf("%d",&T);
    memset(sg,0,sizeof(sg));
    for(int i=0; i<(1<<20); i++)
        sg[i]=make_sg(i);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        int ans=0;
        for(int i=0; i<n; i++)
        {
            int m;
            scanf("%d",&m);
            int state=0,a;
            for(int i=0; i<m; i++)
            {
                scanf("%d",&a);
                state|=(1<<(20-a));
            }
            ans^=sg[state];
        }
        if(ans)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 、4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看rEADME.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值