# Expanding Rods//POJ - 1905//二分

Expanding Rods//POJ - 1905//二分


题目

When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.
Input
The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output
For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.
Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output
61.329
225.020
0.000
题意
给你原长L,温度改变量n和系数c,求弯曲后中点和原中点的距离
链接:https://vjudge.net/contest/347799#problem/J

思路

纯数学题,计算出公式,利用1e-8精度保证答案正确。

代码

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include <queue>
#include <cmath>
using namespace std;

const double min = 1e-8;                           //精度设置成1e8
int main()
{
    double L,c,n,s,r,h;
    while(1){
        cin>>L>>n>>c;
        if(L<0&&n<0&&c<0) break;
        s=(1+n*c)*L;
        double low = 0;
        double high = L/2;                          //最大不超过原长1/2
        double mid;
        while(high-low>min){
            mid = (high + low)/2;
            r=(4*mid*mid+L*L)/(8*mid);            //直接套公式
            if(2*r*asin(L/(2*r))<s)               //偏小
                low=mid;
            else                                  //偏大
                high=mid;
        }
        printf("%.3lf\n",mid);
    }
    return 0;
}


注意

注意循环条件的设置,避免死循环

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值