人口普查

1.题目:人口普查

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:
输入在第一行给出正整数 N,取值在(0,10^5];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年//日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:
在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John

代码

方法一:(该方法在OJ上完全正确)
该方法是找到最大年龄或者最小年龄,直接赋值给一个临时最大或最小实体

#include <stdio.h>
#include <string.h>

struct People{
	char name[6];
	char time[11];
};

int main(){
	char minTime[11] = "1814/09/06";
	char maxTime[11] = "2014/09/06";
	int number;
	int index = 0;
	scanf("%d", &number);
	struct People peopleBig;
	struct People peopleSmall;
	for(int i = 0; i<number; i++){
		struct People people;
		scanf("%s %s", &people.name, &people.time);
	
		if(strcmp(people.time, minTime) >=0 && strcmp(maxTime, people.time) >= 0){
			if(index == 0){
				peopleBig = peopleSmall = people;
			}
			index++;
			if(strcmp(people.time, peopleBig.time) < 0){
				peopleBig = people;
			}else if(strcmp(peopleSmall.time, peopleBig.time) <= 0){
				peopleSmall = people;
			}
		}
	}
	if(index > 0){
		printf("%d %s %s", index, &peopleBig.name, &peopleSmall.name);
	}else{
		printf("%d", index);
	}
	
	return 0;
}

方法二:(该方法在OJ上对三分之一)
用max和min作为标记位,记录最大年龄和最小年龄

#include <stdio.h>
#include <string.h>
struct People{
	char name[6];
	char date[11];
};

int main(){
	char minTime[11] = "1814/09/06";
	char maxTime[11] = "2014/09/06";
	int index = 0;
	int n;
	scanf("%d", &n);			//输入学生个数 
	struct People arr[n];
	int max = 0, min = 0;
	for(int i = 0; i<n; i++){	//输入数据 
		scanf("%s %s", arr[i].name, arr[i].date);	
	}
	
	for(int i = 0; i<n; i++){
		if(strcmp(arr[i].date,minTime) >=0 && strcmp(maxTime,arr[i].date) >= 0){		//判断数据是合理的 
			index++;
			if(strcmp(arr[i].date, arr[max].date) >= 0){
				max = i;	//若当前比最大的日期大,则实际年龄小 
			}else if(strcmp(arr[i].date, arr[min].date) <= 0){
				min = i;	//若当前比最小时间小,则实际年龄大 
			}
		}		
	}
 	
 	printf("%d %s %s", index, arr[min].name, arr[max].name);

	return 0;
}

方法二能在PAT上正确输出部分,但我不知道哪里有问题,欢迎评论区留言。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值