LCS:最长公共子序列

1.什么是最长公共子序列LCS

    给定两个序列X和Y,称序列Z是X和Y的公共子序列,如果Z既是X的一个字序列,又是Y的一个子序列,长度最长的那一个就是我们所说的LCS(Longest-Common-Subsequent)。

    例如:X ={A,B,C,B,D,A,B},Y={B,D,C,A,B,A} 。{B,C,A}是他们的一个子序列,但是不LCS。因为LCS得长度为4,如{B,C,B,A}、{B,D,A,B}。

 

 

 

2.POJ1458-求LCS长度

 

Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16895 Accepted: 6509

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
#include<iostream>
#include<utility>
#include<string>
using namespace std;
int main()
{
 string s1,s2;
 int len1,len2,i,j;
 while( cin>>s1>>s2){
  len1= s1.length();
  len2 = s2.length();
  int **table = new int *[len1+1];
  for( i = 0; i <= len1; i++) table[i] = new int[len2+1];
  for( i = 0; i <= len1; i++) table[i][0] = 0;
  for( j= 0; j <= len2; j++) table[0][j] = 0;
  for( i = 1; i <= len1; i++){
   for( j = 1; j <= len2; j++){
    if( s1[i-1] == s2[j-1])
     table[i][j] = table[i-1][j-1] + 1;
    else
     table[i][j] =max( table[i][j-1] , table[i-1][j]);
   }
  }
  cout<<table[len1][len2]<<endl;
 }
 return 0;
}
3.POJ2250-求LCS
 
 
Compromise
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2423 Accepted: 1164 Special Judge

Description

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do.

Therefore the German government requires a program for the following task:
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind).

Your country needs this program, so your job is to write it for us.

Input

The input will contain several test cases.
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'.
Input is terminated by end of file.

Output

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

Sample Input

die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output

die einkommen der abgeordneten muessen dringend verbessert werden
#include<iostream>
#include<utility>
#include<string>
using namespace std;
int main()
{
 string s1[101],s2[101],result[101];
 int table[101][101],opt[101][101];
 while( cin>>s1[0]){
  int len1 = 1,len2 = 1;
  while( s1[len1-1] != "#")
   cin>>s1[len1++];
  --len1;
  cin>>s2[0];
  while( s2[len2-1] != "#")
   cin>>s2[len2++];
  --len2;
  int i,j;
  for( i = 0; i <= len1; i ++) table[i][0] = 0;
  for( j =0; j <= len2; j++) table[0][j] = 0;
  for( i = 1; i <= len1; i++){
   for( j = 1; j <= len2; j++){
    if( s1[i-1] == s2[j-1]){
     table[i][j] = table[i-1][j-1] + 1;
     opt[i][j] = 0;
    }else{
     if( table[i][j-1] >= table[i-1][j]){
      table[i][j] = table[i][j-1];
      opt[i][j] = 1;
     }else{
      table[i][j] = table[i-1][j];
      opt[i][j] = 2;
     }
    }
   }
  }
  int n = table[len1][len2];
  cout<<n<<endl;
  int p = n;
  i = len1;
  j = len2;
  while( n){
   while( opt[i][j]){
    if( opt[i][j] == 1) --j;
    else --i;
   }
   --n;
   --i;
   --j;
   result[n] = s1[i];
  }
  for( i = 0; i < p-1 ; i++){
   cout<<result[i]<<" ";
  }
  cout<<result[p-1]<<endl;
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值