Pangu and Stones 解题报告

题目:

描述

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

输入

There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai  <=1000,i= 1…N ), indicating the number of stones of  pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

输出

For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output  0.

样例输入
3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4
样例输出
9
6
0


题目分析:

感觉像事DP问题,后来发现也其中部分可以利用DFS的思想;

依题意,越靠前的数组就会被使用越多的次数,所以从开始就要尽可能长的合并石堆

利用DFS的思想对石堆进行合并,并进行标记的次数

那么就要从后向前进行;

同时比较以标记次数和现在进行次数的大小,如果现在的次数要比之前标记的次数要大,就直接return

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm> 
using namespace std ;
#define MAX 10000
int N,L,R;
int pile[1010];
int flag[1010];
bool pos = 0;
void DFS(int n,int t,int s)	{
	for (int i=n-t+2;i<=n;++i)	
		if(flag[i]<s)					return;
	if(n-t+1<1)							return;
	if(n-t+1==1)	{
		for (int i=1;i<=n;++i)			flag[i]=s;
		pos = 1;
		return ;
	}
	for (int i=n-t+2;i<=n;++i)			flag[i]=s;
	for (int i=L;i<=R;++i)				DFS(n-i+1,i,s+1);
	return ;
}

int main()
{
	while (cin>>N>>L>>R)	{
		pos = 0;
		memset(flag,MAX,sizeof(flag));
		for (int i=1;i<=N;++i)			cin>>pile[i];
		for (int i=L;i<=R;++i)			DFS(N,i,1);
		if(pos)		{
			int sum=0;
			for (int i=1;i<=N;++i)	{
				sum+=(pile[i]*flag[i]);
			}
			cout<<sum<<endl;
		}
		else 	cout<<"0"<<endl;
	}	
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值