GCC
总提交:157 测试通过:48
描述
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
输入
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
输出
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.
Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
样例输入
1
10 861017
样例输出
593846
题目来源
2009武汉赛区网络赛
题目上传者
qingyezhu
解题思路:atoi函数
atoi是ASCII to integer 的缩写,是把字符串转换成长整型数的一种函数
AC代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main()
{
int i,t;
__int64 s,n,m,x;
char a[200],b[200];
scanf("%d",&t);
getchar();
while(t--)
{
scanf("%s%s",a,b);
m=atoi(b);
if(strlen(a)>strlen(b))
n=m;
else
n=atoi(a);
s=1;x=1;
for(i=1;i<=n;i++)
{
x*=i;
x%=m;
s+=x;
s%=m;
}
printf("%d\n",s%m);
}
return 0;
}