1064. Complete Binary Search Tree (30)

1064. Complete Binary Search Tree (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
题目的整体思路就是建立有n个节点的完全二叉树(使用广度优先搜索的思路), 将给出的n个数值按升序排列,然后用中序遍历将这些数值分配到对应的完全二叉树的节点上,最后再广度优先搜索分层输出就行(只要按照节点的序号进行输出就行)。
#include <iostream>
#include <vector>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
vector<int> keys;
map<int,vector<int> >tree;
void inor_traversal(int root);
int num,cnt=0;
int main()
{
    cin >>num;
    for(int i=0;i<num;i++)
    {
        int tmp;
        cin >>tmp;
        keys.push_back(tmp);
    }
    sort(keys.begin(),keys.end());
    queue<int> q;
    int tmp,i=0;
    q.push(i);
    while(!q.empty())
    {
        tmp=q.front();
        q.pop();
        i++;
        if(i<num)
        {
            tree[tmp].push_back(i);
            q.push(i);
        }
        else
            tree[tmp].push_back(-1);
        i++;
        if(i<num)
        {
            tree[tmp].push_back(i);
            q.push(i);
        }
        else
            tree[tmp].push_back(-1);
    }
    inor_traversal(0);
    i=0;
    cout <<tree[i].at(2);
    for(int i=1;i<num;i++)
        cout <<" "<<tree[i].at(2);
    cout <<endl;
    return 0;
}
void inor_traversal(int root)
{
    int tmp=tree[root].at(0);
    if(tmp!=-1)
        inor_traversal(tmp);
    tree[root].push_back(keys[cnt]);
    cnt++;
    tmp=tree[root].at(1);
    if(tmp!=-1)
        inor_traversal(tmp);
    return;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值