HDU5791(2016多校第五场)——Two(动态规划)

Two

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1543    Accepted Submission(s): 680


Problem Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.
 

Input
The input contains multiple test cases.

For each test case, the first line cantains two integers  N,M(1N,M1000) . The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.
 

Output
For each test case, output the answer mod 1000000007.
 

Sample Input
  
  
3 2 1 2 3 2 1 3 2 1 2 3 1 2
 

Sample Output
  
  
2 3
 

Author
ZSTU
 

Source
 


题意:找到两个序列里面相同子序列的个数

思路:两个数组,dp[i][j]表示以a[i]和b[j]结尾的相同子序列的个数。f[i][j]表示a的前i个数,b的前j个数组成的序列,相同的子序列的个数。

然后分a[i]=b[j]和a[i]!=b[j]讨论即可。

具体可以看代码。


#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
using namespace std;

const int INF=1000000007;
const int MAXN =1010;
const int MAXM=1000010;
const int MODE=1000000007;


int n,m;
long long a[MAXN];
long long b[MAXN];
long long dp[MAXN][MAXN];
long long f[MAXN][MAXN];
int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        memset(dp,0,sizeof(dp));
        memset(f,0,sizeof(f));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=1;i<=n;i++)
            scanf("%I64d",a+i);
        for(int j=1;j<=m;j++)
            scanf("%I64d",b+j);
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                if(a[i]==b[j]){
                    dp[i][j]=(f[i-1][j-1]+1)%MODE;
                    f[i][j]=(f[i-1][j]+f[i][j-1]-f[i-1][j-1]+dp[i][j]+MODE)%MODE;
                }
                else{
                    f[i][j]=(f[i-1][j]+f[i][j-1]-f[i-1][j-1]+MODE)%MODE;
                    dp[i][j]=0;
                }
            }
        }
        printf("%I64d\n",f[n][m]);
    }
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值