HDU2845--Beans

Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

Output
For each case, you just output the MAX qualities you can eat and then get.

Sample Input
  
  
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6

Sample Output
242

 

/*
首先求出每行我们能取得最大值
*/
#include <iostream>
#include <cstdio>
using namespace std;
#define maxn 200008
int key[maxn];
int sum[maxn];//用来存每一行能取得的最大值
int dp[maxn];
inline int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int r,c;
    while(scanf("%d%d",&r,&c)==2)
    {
        for(int i=1;i<=r;i++)
        {
            for(int j=1;j<=c;j++)
            {
                scanf("%d",&key[j]);
                if(j==1)dp[j]=max(0,key[j]);
                else
                {
                    dp[j]=max(dp[j-1],dp[j-2]+key[j]);
                }
            }
            sum[i]=dp[c];
        }
        //好吧,这样我就求出每行能拿的最大值了
        dp[1]=sum[1];
        for(int i=2;i<=r;i++)
        {
            dp[i]=max(dp[i-1],dp[i-2]+sum[i]);
        }
        printf("%d\n",dp[r]);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值