POJ1286--Necklace of Beads

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there?

Input

The input has several lines, and each line contains the input data n.
-1 denotes the end of the input file.

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39
#include<stdio.h>
int m,n;
long long ans;
long long pw(int x,int y)x的y次幂
{
	if(y==0)
	return 1;
	return x*pw(x,y-1);
}
int gcd(int a,int b)
{
	if(b==0)		return a;
	return gcd(b,a%b);
}
int main()
{
	//freopen("in.txt","r",stdin);
	while(scanf("%d",&n)!=EOF && n!=-1)/m是那个颜色数目,n是珠子数
	{
		if(n == 0)	
		{	printf("0\n");	continue;	}
		ans=0;
		for(int i=1;i<=n;i++)
		ans+=pw(3,gcd(n,i));
		if((n&1) == 1)	ans+=n*pw(3,(n+1)>>1);
		else		
		{
			ans+=(n>>1)*pw(3,(n+2)>>1);
			ans+=(n>>1)*pw(3,n>>1);
		}
		printf("%I64d\n",ans/2/n);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值