PAT_A 1030. Travel Plan (30)

1030. Travel Plan (30)

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.
Sample Input

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output

0 2 3 3 40

  • 分析:30分这种题就是考数据结构,题目意思很明确。寻找最短路径,最短路径不唯一,但可通过花费找到唯一的一条。alg:dijkstra(找到所有的最短路径)+dfs(找到其中花费最少的那条)。

  • code:

#include<iostream>
#include<climits>//INT_MAX头文件
#include<vector>
using namespace std;
const int MAX=INT_MAX;
int N,M,S,D;
int dist[510][510],cost[510][510];
int visit[510];
vector<int>pre[510];
//dfs选出相同路径中花费最少的
int dfs(int d,int c)
{
    if(d==S)
      return c;
    int tmp_a,tmp_b,min;
    tmp_b=MAX;
    //选出花费最少
    for(int i=0;i<pre[d].size();i++)
    {
        tmp_a=dfs(pre[d].at(i),c+cost[d][pre[d].at(i)]);
        if(tmp_a<tmp_b)
        {
            tmp_b=tmp_a;
            min=pre[d].at(i);
        }
    }
    cost[min][min]=d;//路径链接
    return tmp_b;
}
int main()
{
    //保存记录
    fill(cost[0],cost[0]+510*510,MAX);
    fill(dist[0],dist[0]+510*510,MAX);
    fill(visit,visit+510,0);

    cin>>N>>M>>S>>D;
    int tmp_a,tmp_b;
    for(int i=0;i<M;i++)
    {
        cin>>tmp_a>>tmp_b;
        cin>>dist[tmp_a][tmp_b];
        cin>>cost[tmp_a][tmp_b];
        dist[tmp_b][tmp_a]=dist[tmp_a][tmp_b];
        cost[tmp_b][tmp_a]=cost[tmp_a][tmp_b];
    }
    //dijkstra找出最短路径
    int min=S;
    dist[min][min]=0;
    int min_cost=MAX;
    //dijkstra算法
    while(true)
    {
        //get min
        min_cost=MAX;
        for(int i=0;i<N;i++)
        {
            if(visit[i]==0&&dist[i][i]<min_cost)
            {
                min_cost=dist[i][i];
                min=i;
            }
        }
        if(visit[min]==1)
          break;
        dist[min][min]=min_cost;
        visit[min]=1;
        //relax 松弛
        for(int i=0;i<N;i++)
        {
            if(visit[i]==1||dist[min][i]==MAX)
              continue;
            if(dist[min][min]+dist[min][i]<dist[i][i])
            {
                dist[i][i]=dist[min][min]+dist[min][i];
                pre[i].clear();
                pre[i].push_back(min);
                //最短路径不是一条
            }else if(dist[min][min]+dist[min][i]==dist[i][i])
                pre[i].push_back(min);
        }
    }
    min_cost=dfs(D,0);
    int cur=S;
    while(true)
    {
        cout<<cur<<" ";
        cur=cost[cur][cur];
        if(cur==D)
          break;
    }
    cout<<cur<<" "<<dist[D][D]<<" "<<min_cost<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
select distinct a.EMPI_ID, a.PATIENT_NO, a.MR_NO, a.PAT_NAME, a.PAT_SEX, a.PAT_AGE, a.PAT_PHONE_NO, b.DIAG_RESULT, a.ADMIT_DATE, a.DISCHARGE_DEPT_NAME, a.ATTEND_DR from BASIC_INFORMATION a join PA_DIAG b on a.MZZY_SERIES_NO=b.MZZY_SERIES_NO join EXAM_DESC_RESULT_CODE c on a.MZZY_SERIES_NO=c.MZZY_SERIES_NO join DRUG_INFO d on a.MZZY_SERIES_NO=d.MZZY_SERIES_NO join EMR_CONTENT e on a.MZZY_SERIES_NO=e.MZZY_SERIES_NO JOIN TEST_INFO A17 ON a.MZZY_SERIES_NO = A17.MZZY_SERIES_NO where a.PAT_AGE>='18' and (to_char(a.ADMIT_DATE,'YYYY-MM-DD') >= '2021-01-01') AND (b.DIAG_RESULT LIKE '%鼻咽癌%' or b.DIAG_RESULT LIKE '%鼻咽恶性肿瘤%' or b.DIAG_CODE LIKE '%C11/900%') and d.DRUG_NAME not in (select DRUG_NAME FROM DRUG_INFO WHERE DRUG_NAME like '卡培他滨') and b.DIAG_RESULT NOT IN (SELECT DIAG_RESULT FROM PA_DIAG WHERE DIAG_RESULT LIKE '%HIV阳性%') and b.DIAG_RESULT NOT IN (SELECT DIAG_RESULT FROM PA_DIAG WHERE DIAG_RESULT LIKE '%充血性心力衰竭%') AND to_char(( A17.TEST_DETAIL_ITEM_NAME = '中性粒细胞' AND A17.TEST_RESULT >= 1.5 ) OR ( A17.TEST_DETAIL_ITEM_NAME = '血小板' AND A17.TEST_RESULT >= 100 ) OR ( A17.TEST_DETAIL_ITEM_NAME = '血红蛋白' AND A17.TEST_RESULT >= 9 ) OR ( A17.TEST_DETAIL_ITEM_NAME = '丙氨酸氨基转移酶' AND A17.TEST_RESULT <= 2.5 ) OR ( A17.TEST_DETAIL_ITEM_NAME = '天门冬氨酸氨基转移酶' AND A17.TEST_RESULT <= 2.5 ) OR ( A17.TEST_DETAIL_ITEM_NAME = '肌酐清除率' AND A17.TEST_RESULT > 51 ) OR ( A17.TEST_DETAIL_ITEM_NAME = '肌酐' AND A17.TEST_RESULT <=1.5 ) OR ( A17.TEST_DETAIL_ITEM_NAME = '凝血酶原时间' AND A17.TEST_RESULT <= 1.5 ))语句哪里有问题
最新发布
06-07

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值