1143. Lowest Common Ancestor (30)

1143. Lowest Common Ancestor (30)

  • 题目:

    The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

    A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

    The left subtree of a node contains only nodes with keys less than the node’s key.
    The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
    Both the left and right subtrees must also be binary search trees.
    Given any two nodes in a BST, you are supposed to find their LCA.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 1000), the number of pairs of nodes to be tested; and N (<= 10000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

    Output Specification:

    For each given pair of U and V, print in a line “LCA of U and V is A.” if the LCA is found and A is the key. But if A is one of U and V, print “X is an ancestor of Y.” where X is A and Y is the other node. If U or V is not found in the BST, print in a line “ERROR: U is not found.” or “ERROR: V is not found.” or “ERROR: U and V are not found.”.

    Sample Input:
    6 8
    6 3 1 2 5 4 8 7
    2 5
    8 7
    1 9
    12 -3
    0 8
    99 99
    Sample Output:
    LCA of 2 and 5 is 3.
    8 is an ancestor of 7.
    ERROR: 9 is not found.
    ERROR: 12 and -3 are not found.
    ERROR: 0 is not found.
    ERROR: 99 and 99 are not found.

  • 分析:
    题目很简单,结构也很简单,但是就是有一个测试点超时!!,从tree–>map–>set 仍旧没有解决,最后,改成在发现ancestor时,接着往下找,看存在不存在,这样最多访问一次树,就结束。终于AC了,但也是险些超时。不明白在哪费时~~~???

  • code:
#include<iostream>
using namespace std;
struct T
{
    int v;
    T*l;
    T*r;
    T()
    {
        l=r=NULL;
    }
};
T*root=NULL;
void CT(T* &root,int v)
{
    if(root==NULL)
    {
        root=new T;
        root->v=v;
        return;
    }
    if(v<root->v)CT(root->l,v);
    else CT(root->r,v);
}
//vector<int>vt2;
//改成组合,第一判断p,第二深入孩子,一次完整的遍历杰克 
int ex(T*root,int v)
{
    if(root==NULL)return -1;
    if(root->v<v)return ex(root->r,v);
    else if(root->v>v) return ex(root->l,v);
    else return 1;
}
void show(T*root,int l,int r)
{
        int ll=ex(root,l);
        int rr=ex(root,r);
        if(ll==1&&rr==1)
        {
            int v=0;
            if(root!=NULL)
                v=root->v;
            if(v==l)
                printf("%d is an ancestor of %d.\n",l,r);
            else if(v==r)
                printf("%d is an ancestor of %d.\n",r,l);
            else
                printf("LCA of %d and %d is %d.\n",l,r,v);
        }
        else if(ll!=1&&rr!=1)
            printf("ERROR: %d and %d are not found.\n",l,r); 
        else if(ll!=1)
            printf("ERROR: %d is not found.\n",l);
        else if(rr!=1)
            printf("ERROR: %d is not found.\n",r);
}
int test(T*root,int l,int r)
{
    if(root==NULL)
    {
        show(root,l,r);
        return -1;
    }
    int v=root->v;
    if(v<l&&v<r)
    {
        return  test(root->r,l,r);
    }else if(v>r&&v>l)
    {
        return test(root->l,l,r);
    }else
    {
        show(root,l,r);
        return v;
    }

} 
int main()
{
    freopen("in.txt","r",stdin);
    int M,N,tmp;
    scanf("%d%d",&M,&N);
    for(int i=0;i<N;i++)
    {
        scanf("%d",&tmp);
        CT(root,tmp);
    }
    int t1,t2;
    bool in1,in2;
    for(int i=0;i<M;i++)
    {
        //cin>>t1>>t2;
        scanf("%d%d",&t1,&t2);
        test(root,t1,t2);
    }
    return 0;
}
  • AC
    AC
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值