暑假集训日记--8.4--搜索

哇……今天比昨天还失败

感觉自己越来越菜了……

今天只出了一道题。用了一下午加一晚上的时间研究了一道题。。。到现在还没法记录路径。。。要不就一直Runtime Error。。

这道题明天一定要A,A后写博客

感觉是方法有问题。。。

今天没啥……一直在绞尽脑汁的解决问题……

待把那道题出了。。再写博客……

感觉心态炸了……

附今天唯一A的题的代码吧。。、

Problem Description
A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).
 

Input
The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). <br>Output file must contain a single integer -- the maximum traffic between the subnetworks. <br>
 

Output
Output must contain a single integer -- the maximum traffic between the subnetworks.
 

Sample Input
  
  
3 0 50 30 50 0 40 30 40 0
 

Sample Output
  
  
90

题意就是把所有的点分成两部分,求权值最大的组合的值。

源代码:


#include <iostream>
#include <cstring>
#include <algorithm>
#include <string>
#include <stdio.h>
#include <cmath>
using namespace std;
int n,num[100][100],flag[100],max1;
void DFS(int i, int sum)
{
    flag[i] = 1;
    int sum1 = sum;
    for (int j = 1; j <= n; j++)
    {
        if (flag[j] == 0)
            sum1 = sum1 + num[i][j];
        else
            sum1 = sum1 - num[i][j];
    }
    int j;
    max1 = max(sum1,max1);
    //cout << max1 << endl;
    for (j = i + 1; j <= n; j++)
    {
            DFS(j,sum1);
            flag[j] = 0;
    }
}
int main()
{
    int i,j;
    scanf("%d",&n);
    for (i = 1; i <= n; i++)
        for (j = 1; j <= n; j++)
            scanf("%d", &num[i][j]);
    memset(flag,0,sizeof(flag));
    max1 = 0;
    DFS(1,0);
    printf("%d\n",max1);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值