B-number(数位dp)

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n. 
Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
Output
Print each answer in a single line.
Sample Input
13
100
200
1000
Sample Output
1
1
2
2


数位dp的板题。

源代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <stdio.h>
typedef long long ll;
using namespace std;
int dp[20][20][3];
int a[20];
ll n;
//status用于表示当前的状态,即数组中的第三维的值。
//若status == 0表示末尾不是1,status == 1 表示末尾是1,status == 2 表示含有13
ll dfs(int pos,int status,int mod,bool limit){
    if (pos == 0)
        return mod == 0 && status == 2;
    if (!limit && dp[pos][mod][status] != -1)
        return dp[pos][mod][status];
    int up = limit?a[pos]:9;//用于限制防止超出最大值
    ll ans = 0;
    //此处不需要考虑前导零
    for (int i = 0; i <= up; i++){
        int modd = (mod*10+i)%13;
        int statuss = status;
        if(status == 0 && i == 1)
            statuss = 1;
        if (status == 1 && i != 1)
            statuss = 0;
        if (status == 1 && i == 3)
            statuss = 2;
        ans += dfs(pos-1,statuss,modd,limit&&i==up);//套路……
    }
    if (!limit)
        dp[pos][mod][status] = ans;
    return ans;
}
ll solve(ll n){
    int length = 0;
    while (n){
        a[++length] = n % 10;
        n /= 10;
    }
    return dfs(length,0,0,1);
}
int main(){
    while (scanf("%lld",&n)!=EOF){
        memset(a,0,sizeof(a));
        memset(dp,-1,sizeof(dp));
        printf("%lld\n",solve(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值