TELE(树形dp+背包)

题目:TELE

A TV-network plans to broadcast an important football match. Their network of transmitters and users can be represented as a tree. The root of the tree is a transmitter that emits the football match, the leaves of the tree are the potential users and other vertices in the tree are relays (transmitters).

The price of transmission of a signal from one transmitter to another or to the user is given. A price of the entire broadcast is the sum of prices of all individual signal transmissions.
Every user is ready to pay a certain amount of money to watch the match and the TV-network then decides whether or not to provide the user with the signal.
Write a program that will find the maximal number of users able to watch the match so that the TV-network's doesn't lose money from broadcasting the match.
Input
The first line of the input file contains two integers N and M, 2 <= N <= 3000, 1 <= M <= N-1, the number of vertices in the tree and the number of potential users.
The root of the tree is marked with the number 1, while other transmitters are numbered 2 to N-M and potential users are numbered N-M+1 to N.
The following N-M lines contain data about the transmitters in the following form:
K A1 C1 A2 C2 ... AK CK
Means that a transmitter transmits the signal to K transmitters or users, every one of them described by the pair of numbers A and C, the transmitter or user's number and the cost of transmitting the signal to them.
The last line contains the data about users, containing M integers representing respectively the price every one of them is willing to pay to watch the match.
Output
The first and the only line of the output file should contain the maximal number of users described in the above text.
Sample Input
9 6
3 2 2 3 2 9 3
2 4 2 5 2
3 6 2 7 2 8 2
4 3 3 3 1 1
Sample Output

5

题意:电视台向很多用户发送信号,每个用户有愿意出的钱,电视台经过的路线都有一定的费用,求电视台在不损失的情况下最多能给多少用户发送信号。即给一棵树,根结点表示发射塔,叶子结点表示用户,树的每一条边的权值表示传输需要的代价。

输入:第一行表示树的节点数n和用户数m,之后的n-m行第一个数k表示临近的点数,之后的数表示它临近的节点和边权,最后一行表示m个用户愿意出的钱。

思路:树形dp+背包

由于求的是最多多少用户,所以以用户为状态,设置一个二维dp数组。

dp[i][j]表示第i个结点为根结点的子树j个用户的时候最大的剩余费用。

价值有可能是负值,所以初始化数组时dp数组要初始化为负数

源代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <stdio.h>
#include <iomanip>
#include <cmath>
#include <vector>
#define maxn 10005
using namespace std;
struct Tree{
    int to,next,v;
}tree[maxn];
int dp[maxn][maxn];
int n,m;
int head[maxn];
int num[maxn];
int a[maxn];
int sum;
void add(int a,int b,int v){
    tree[sum].to = b;
    tree[sum].v = v;
    tree[sum].next = head[a];
    head[a] = sum;
    sum++;
}
void tree_dp(int x){
    for (int i = head[x]; i != -1; i = tree[i].next){
        tree_dp(tree[i].to);
        for (int j = 0; j <= num[x]; j++)
            a[j] = dp[x][j];
        for (int j = 0; j <= num[x]; j++){
            for (int t = 1; t <= num[tree[i].to]; t++){
                dp[x][j+t] = max(dp[x][j+t],a[j] + dp[tree[i].to][t]-tree[i].v);
            }
        }
        num[x] += num[tree[i].to];
    }
}
int main(){
    while (scanf("%d%d",&n,&m)!=EOF){
        int a,b,k;
        sum = 0;
        memset(head,-1,sizeof(head));
        memset(num,0,sizeof(num));
        for (int i = 1; i <= n-m; i++){
            scanf("%d",&k);
            while (k--){
                scanf("%d%d",&a,&b);
                add(i,a,b);
            }
        }
        for (int i = 1; i <= n; i++)
            for (int j = 1; j <= n; j++)
                dp[i][j] = -999999;
        //memset(dp,-9999999,sizeof(dp));
        for (int i = n-m+1; i <= n; i++){
            num[i] = 1;//每个叶子结点为一个用户
            scanf("%d",&dp[i][1]);
        }
        tree_dp(1);
        for (int i = m; i >= 0; i--){
            if (dp[1][i] >= 0){
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值