H - Hello World!

Description

We know that Ivan gives Saya three problems to solve (Problem F), and this is the first problem.
We need a programmer to help us for some projects. If you show us that you or one of your friends is able to program, you can pass the first hurdle.
I will give you a problem to solve. Since this is the first hurdle, it is very simple.”
We all know that the simplest program is the “Hello World!” program. This is a problem just as simple as the “Hello World!”
In a large matrix, there are some elements has been marked. For every marked element, return a marked element whose row and column are larger than the showed element’s row and column respectively. If there are multiple solutions, return the element whose row is the smallest; and if there are still multiple solutions, return the element whose column is the smallest. If there is no solution, return -1 -1.
Saya is not a programmer, so she comes to you for help
Can you solve this problem for her?

Input

The input consists of several test cases.
The first line of input in each test case contains one integer N (0<N1000), which represents the number of marked element.
Each of the next N lines containing two integers r and c, represent the element’s row and column. You can assume that 0<r, c300. A marked element can be repeatedly showed.
The last case is followed by a line containing one zero.

Output

For each case, print the case number (1, 2 …), and for each element’s row and column, output the result. Your output format should imitate the sample output. Print a blank line after each test case.

Sample Input

3
1 2
2 3
2 3

0

Sample Output

Case 1:
2 3
-1 -1
-1 -1

解题思路;
题意为对于输入的每对坐标寻找另一对行坐标和列坐标都比它大的坐标,如果没有输出-1 ,-1如果有多对则输出行坐标小的,如果行坐标也相同则输出列坐标小的,

代码:

#include <iostream>
#include<string>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
    int n,i,j,flag;
    int r[1001];
    int c[1001];
    int r1[1001];
    int c1[1001];
    int num=0;
    while(cin>>n)
    {
        num++;
        if(n==0) break;
        for(i=0;i<n;i++)
        {cin>>r[i];cin>>c[i];}
        for(i=0;i<=n;i++)
        {
            r1[i]=c1[i]=400; flag=0;
            for(j=0;j<=n;j++)
            {
                if(r[j]>r[i]&&c[j]>c[i])
                {
                    flag=1;
                    if(r1[i]>r[j]) {r1[i]=r[j];c1[i]=c[j]; }
                    if(r1[i]==r[j]&&c1[i]>c[j]) {r1[i]=r[j];c1[i]=c[j];}
                }
            }
            if(flag==0) r1[i]=c1[i]=-1;
        }
        cout<<"Case "<<num<<":"<<endl;
        for(i=0;i<n;i++)
        {cout<<r1[i]<<" "<<c1[i]<<endl;}
        cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值