B - 1002

B - 1002
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.

Now given the center and radius of two circles, your job is to find how many common tangents between them.

Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.

Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.

Sample Input

3
10 10 5 20 20 5
10 10 10 20 20 10
10 10 5 20 10 5

Sample Output

4
2
3

 

解题思路:

对于每组数据,计算两圆心简的距离(x),与半径之和(y)作比较,

细节处理:

圆心间距离小于半径之和时还分多种情况,包括内切,相交和包含,对于两圆重合时,切线无穷多,输出-1

代码 :

#include <iostream>
#include<vector>
#include<algorithm>
#include<cstdio>
#include<string>
#include<map>
#include<cmath>
using namespace std;
int main()
{
    int i,t;
    cin>>t;
    double x1,x2,y1,y2,r1,r2;
    while(t--)
    {
        cin>>x1>>y1>>r1>>x2>>y2>>r2;
        double dis=pow(x1-x2,2)+pow(y1-y2,2);
        double x=sqrt(dis);
        double y=fabs(r1+r2);
        double rmax=r1>r2?r1:r2;
        double rmin=r1<r2?r1:r2;
        int num;
        if(x==0&&r1==r2) num=-1;
        else  {
        if(x==y) num=3;
        else if(x<y)
        { if(x<rmax-rmin) num=0;
        else {if(x==rmax-rmin) num=1; else num=2;}}
        else if(x>y) num=4;}
        cout<<num<<endl;
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值