Channel Allocation-(dfs)

Channel Allocation

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 37   Accepted Submission(s) : 18
Problem Description
When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.
 

Input
The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. <br> <br>Following the number of repeaters is a list of adjacency relationships. Each line has the form: <br> <br>A:BCDH <br> <br>which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form <br> <br>A: <br> <br>The repeaters are listed in alphabetical order. <br> <br>Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. <br>
 

Output
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.
 

Sample Input
  
  
2 A: B: 4 A:BC B:ACD C:ABD D:BC 4 A:BCD B:ACD C:ABD D:ABC 0
 

Sample Output
  
  
1 channel needed. 3 channels needed. 4 channels needed.

题意:

给n个中继器,以及每个中继器给出其相邻的中继器,相邻中继器不能用一样频率,问最少要多少频率

解题思路:

一次AC的题。将相邻关系放入矩阵,逐个中继器选完频率后将其相邻中继器也选定

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
using namespace std;
int n,cnt,m[27][27];
char s[27][27];
bool ok[27];
void dfs()
{
    for(int i=0;i<n;i++)
    {
        if(ok[i]==false)   //如果i中继器还没选
        {
            ok[i]=true;    //选定
            if(strlen(s[i])!=0) cnt++;  //如果i中继器有相邻中继器,由i创建频率
            else continue;              //如果i中继器没有相邻中继器,i选择和别的相同频率就行,也就没有创建新频率
        }
        for(int j=0;j<(int)strlen(s[i]);j++)
        {
            if(m[i][s[i][j]-'A']==1&&ok[s[i][j]-'A']==false)  //如果i与j相邻,且j还未选
            {
                ok[s[i][j]-'A']=true;
                cnt++;
                m[i][s[i][j]-'A']=0;
                m[s[i][j]-'A'][i]=0;
            }
        }
    }
}
int main()
{
    int i;
    while(scanf("%d",&n)&&n)
    {
        memset(m,0,sizeof(m));
        getchar();
        for(i=0;i<n;i++)
        {
            getchar(); getchar();
            gets(s[i]);                          //s[i]存放i的相邻中继器
            for(int j=0;j<(int)strlen(s[i]);j++) //记录相邻关系
            {
                m[i][s[i][j]-'A']=1;
            }
        }
        bool flag=false;
        for(i=0;i<n;i++)
        {
            if(strlen(s[i])!=0) flag=true;
        }
        if(!flag)          //如果所有中继器都不相邻,就一个频率就够了
        {
            printf("1 channel needed.\n");
            continue;
        }
        cnt=0;
        memset(ok,false,sizeof(ok));
        dfs();
        if(cnt==1) printf("1 channel needed.\n");
        else printf("%d channels needed.\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值