Drying--(二分)

Drying

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 72   Accepted Submission(s) : 22
Problem Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

 

Input
<span lang="en-us"><p>The first line contains a single integer <i>n</i> (1 ≤ <i>n</i> ≤ 100 000). The second line contains <i>a<sub>i</sub></i> separated by spaces (1 ≤ <i>a<sub>i</sub></i> ≤ 10<sup>9</sup>). The third line contains <i>k</i> (1 ≤ <i>k</i> ≤ 10<sup>9</sup>).</p></span>
 

Output
<p>Output a single integer — the minimal possible number of minutes required to dry all clothes.</p>
 

Sample Input
  
  
<b>sample input #1</b> 3 2 3 9 5 <b>sample input #2</b> 3 2 3 6 5
 

Sample Output
  
  
<b>sample output #1</b> 3 <b>sample output #2</b> 2

想到用二分假设这个最小时间,利用此值求出总时间进行判断,枚举mid时,对于每个衣服的用时

因为如果第i件衣服烘干x分钟,风干用mid-x分钟,那么x和mid满足

x*k+(mid-x)>=a[i];----->x>=(a[i]-mid)/(k-1);

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;
int n,k;;
int a[100005];
bool solve(int x)
{
    int sum=0;
    for(int i=1;i<=n;i++)
    {
        if(a[i]<=x) continue;
        sum+=(a[i]-x+k-2)/(k-1);
        if(sum>x) return false;
    }
    return true;
}
int main()
{
    int i;
    while(scanf("%d",&n)!=EOF)
    {
        int maxx=0,ans=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(maxx<a[i]) maxx=a[i];
        }
        scanf("%d",&k);
        if(k==1) {printf("%d\n",maxx); continue;}
        int left=0,right=maxx,mid;
        while(left<=right)
        {
            mid=(left+right)/2;
            if(solve(mid))  //此时sum<=x,也就是用假设的x时间可以烘干所有的,所以保存结果
                {right=mid-1; ans=mid;}
            else
                left=mid+1;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值