HDU-1394-Minimum Inversion Number-(树状数组)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21263    Accepted Submission(s): 12751


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L

题意:给定长为n的降序数组,然后逐步把数组第一个数放到最后,问在这个过程中数组出现最小的逆序数是多少

由题知经n-1次可以换到最终情况,那么在进行一次放置操作时(将a[i]放到最后),逆序数可由放置前的逆序数得到,也就是现在逆序数=上个状态逆序数+(n-a[i])-(a[i]-1);

这里n-a[i]为比a[i]大的数的个数,因为把a[i]放到最后之后,每个比a[i]大的数都可以与a[i]形成一个逆序数,所以加上n-a[i]

而a[i]-1是比a[i]小的数的个数,因为把a[i]放到最后之后,每个比a[i]小的数本来可以与a[i]形成一个逆序数,但是a[i]移走后这个逆序数就没了,所以减去(a[i]-1)

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;
int n;
int a[50005],tree[50005];
inline int min(int a,int b){return a<b?a:b;}
inline int lowbit(int i) {return i&(-i);}
void add(int i,int v)
{
    while(i<=n)
    {
        tree[i]+=v;
        i+=lowbit(i);
    }
}
int sum(int i)
{
    int res=0;
    while(i>0)
    {
        res+=tree[i];
        i-=lowbit(i);
    }
    return res;
}
int main()
{
    int i;
    while(scanf("%d",&n)!=EOF)
    {
        ll temp=0,cnt=0x3f3f3f;
        memset(tree,0,sizeof(tree));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            a[i]++;
            temp+=sum(n)-sum(a[i]);
            add(a[i],1);
        }
        for(i=1;i<n;i++)
        {
            temp+=n-2*a[i]+1;
            cnt=min(cnt,temp);
        }
        printf("%I64d\n",cnt);
    }
    return 0;
}

参考:http://blog.csdn.net/u013480600/article/details/21293613

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值