HDU Problem p

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.<br><br>Write a program to count the number of black tiles which he can reach by repeating the moves described above. <br>
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.<br><br>There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.<br><br>'.' - a black tile <br>'#' - a red tile <br>'@' - a man on a black tile(appears exactly once in a data set) <br>
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). <br>
 

Sample Input
 
 
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 
Sample Output
 
 
45
59
6
13

题意:多少个" . " 与@相连,包括@自己

广搜bfs

code:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include <algorithm>
#include<cstring>
#include <queue>
#include <climits>
using namespace std;
char s[25][25];
int m,n;//m是多少列,n是多少行行
int sum;
int fx[4]={0,0,-1,1},//四个方向
    fy[4]={1,-1,0,0};
void dfs(int x,int y);
bool check(int x,int y);
int main ()
{
    while(~scanf("%d%d",&m,&n)&&(n+m))
    {
        int x,y;
        sum=1;
        for(int i=1;i<=n;++i)
        {
            for(int j=1;j<=m;++j)
            {
                //scanf("%c",&s[i][j]);
                cin>>s[i][j];//表示不懂为什么sscanf不对,少输入一行
                if(s[i][j]=='@')
                {
                    x=i,y=j;
                }
            }
            getchar();
        }
        /*
        for(int i=1;i<=n;++i)
        {
            for(int j=1;j<=m;++j)
            {
                printf("%c",s[i][j]);
            }
            printf("\n");
        }
        */
        s[x][y]='#';
        dfs(x,y);
        /*
        for(int i=1;i<=n;++i)
        {
            for(int j=1;j<=m;++j)
            {
                printf("%c",s[i][j]);
            }
            printf("\n");
        }
        */
        printf("%d\n",sum);
    }
    return 0;
}
void dfs(int x,int y)
{
    int dx,dy;
    for(int i=0;i<=3;++i)
    {
        dx=x+fx[i];
        dy=y+fy[i];
        if(check(dx,dy))
        {
            ++sum;
            s[dx][dy]='#';
            dfs(dx,dy);
        }
    }
    return ;
}
bool check(int x,int y)
{
    if(x>=1&&x<=n&&y>=1&&y<=m)
      if(s[x][y]=='.')
        return true;
    return false;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值