hdu 5365LCP Array

 题目链接:

https://blog.csdn.net/a852852852852/article/details/50811047

LCP Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1841    Accepted Submission(s): 590


 

Problem Description

Peter has a string s=s1s2...sn, let suffi=sisi+1...sn be the suffix start with i-th character of s. Peter knows the lcp (longest common prefix) of each two adjacent suffixes which denotes as ai=lcp(suffi,suffi+1)(1≤i<n).

Given the lcp array, Peter wants to know how many strings containing lowercase English letters only will satisfy the lcp array. The answer may be too large, just print it modulo 109+7.

 

 

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer n (2≤n≤105) -- the length of the string. The second line contains n−1 integers: a1,a2,...,an−1 (0≤ai≤n).

The sum of values of n in all test cases doesn't exceed 106.

 

 

Output

For each test case output one integer denoting the answer. The answer must be printed modulo 109+7.

 

 

Sample Input

 

3 3 0 0 4 3 2 1 3 1 2

 

 

Sample Output

 

16250 26 0

 题目大意:

一个n表示字符串的长度,

给你n-1个数,表示n长度的字符串从第i个字母和第i+1个字母开头的最长公共前缀的长度

要想满足一共n-1个条件,两种情况

1. 最长公共子序列的长度为0

2. 最长公共子序列的长度严格递减(公差为1(因为只有前面的开始的满足了,后面的才能满足)

注意:需要满足第a[i] 要大于n-i(保证有足够长的字符)

This is the code

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<sstream>
#include<stack>
#include<string>
#include<set>
#include<vector>
using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
#define LL long long
#define ULL unsigned long long     //1844674407370955161
#define INT_INF 0x7f7f7f7f      //2139062143
#define LL_INF 0x7f7f7f7f7f7f7f7f //9187201950435737471
// ios::sync_with_stdio(false);
// 那么cin, 就不能跟C的 scanf,sscanf, getchar, fgets之类的一起使用了。
const int dr[]={0, 0, -1, 1, -1, -1, 1, 1};
const int dc[]={-1, 1, 0, 0, -1, 1, -1, 1};
int a[100005];
const LL mod=1e9+7;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<n;++i)
            scanf("%d",&a[i]);
        bool flag=true;
        LL ans=26;
        for(int i=1;i<n;++i)
        {
            if(a[i]==0)
                ans=ans*25%mod;
            if(a[i-1]!=0&&a[i]+1!=a[i-1] || a[i]>n-i)
            {
                flag=false;
                break;
            }
        }
        if(flag)
            printf("%lld\n",ans);
        else
            printf("0\n");
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值