http://acm.sdut.edu.cn/sdutoj/showproblem.php?pid=2467&cid=1131

Steps

Time Limit: 3000MS Memory limit: 65536K

题目描述

 

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

输入

Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers: 0<= x <= y < 231

输出

For each test case, print a line giving the minimum number of steps to get from xto y.

示例输入

3
45 48
45 49
45 50

示例输出

3
3
4
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int n,x,y;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d",&x,&y);
        int dis=y-x,ans=0,flag=1,sum=0,k=0;
        while(ans<dis)
        {
            if(flag==1)k++;
            ans+=k;
            flag*=-1;
            sum++;
        }
        printf("%d\n",sum);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值