The ? 1 ? 2 ? ... ? n = k problem

 

http://acm.sdut.edu.cn/sdutoj/showproblem.php?pid=2468&cid=1131

题目描述

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

输入

 

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

输出

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

示例输入

2

12

-3646397

示例输出

7
2701
k的正负结果是一样的
如-3=-1-2;
   3=+1+2;
要想满足条件则必须1+.....+n>=k;
 
 
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    int test;
    scanf("%d",&test);
    while(test--)
    {
        int  k;
        scanf("%d",&k);
        if(k==0)
        {
            printf("3\n");
            if(test!=0)
             printf("\n");
            continue;
        }
        int p=fabs(k);
        int t=sqrt(2*p);
        int q;
        for(int i=t;; i++)
        {
            int k=(1+i)*i/2-p;
            if(k>=0)
            {
                if(k%2==0)
                {
                    q=i;
                    break;
                }
            }
        }
        printf("%d\n",q);
        if(test!=0)  printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值