uva 357 - Let Me Count The Ways(动态规划-注意dp初始化的问题)

1、http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=293

2、题目大意:给定五种硬币,及一个面值额,看有多少种方法可以组成当前面值额,很简单的dp题目,不过超时了一遍,注意处理这种问题时,dp的初始化只需一遍即可,不需要每次都初始化,后边如果n很大的话,可以用前边用过的dp[][]值,不需要再计算,否则会超时

3、题目

 

Let Me Count The Ways

After making a purchase at a large department store, Mel's change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies. He began to wonder ' "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.

Write a program which will determine the number of different combinations of US coins (penny: 1c, nickel: 5c, dime: 10c, quarter: 25c, half-dollar: 50c) which may be used to produce a given amount of money.

Input

The input will consist of a set of numbers between 0 and 30000 inclusive, one per line in the input file.

Output

The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The number m is the number your program computes, n is the input value.

There are m ways to produce n cents change.

There is only 1 way to produce n cents change.

Sample input

17 
11
4

Sample output

There are 6 ways to produce 17 cents change. 
There are 4 ways to produce 11 cents change. 
There is only 1 way to produce 4 cents change.

 

4、AC代码

#include<stdio.h>
#define N 30005
#define ll long long
#include<string.h>
int v[5]={1,5,10,25,50};
ll dp[7][N];//dp[i][j]表示前i种硬币组成j分的种类数
ll DP(int i,int j)
{
    if(dp[i][j]!=-1)
    return dp[i][j];
    dp[i][j]=0;
    for(int k=0;j-k*v[i]>=0;k++)
    {
        dp[i][j]+=DP(i-1,j-v[i]*k);
    }
    return dp[i][j];
}
int main()
{
    int n;
    memset(dp,-1,sizeof(dp));//在外边只初始化一次即可,否则会超时
    while(scanf("%d",&n)!=EOF)
    {
        
        for(int i=0;i<=n;i++)
        dp[0][i]=1;
        ll ans=DP(4,n);
        if(ans==1)
        printf("There is only 1 way to produce %d cents change.\n",n);
        else
        printf("There are %lld ways to produce %d cents change.\n",ans,n);
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值